Support Questions
Find answers, ask questions, and share your expertise

File dfs_hosts_exclude.txt not created

New Contributor

Hi All,

 

I tried decommissioning a large DataNode, through by excluding hosts. But when I added host in the settings HDFS -> CONFIGURATION -> SERVICE WIDE -> ADVANCED ->  HDFS Service Environment Safety Valve  (Safety Valve) for dfs_hosts_exclude.txt, the file dfs_hosts_exclude.txt is not created. I tried to restart the service but nothing happens, hosts are not added to the configuration.

 

Now I'm using Cloudera 5.15, on version 5.14 there was no problem with this.

 

 

Decommissioning DataNodes Using the Command Line - also did not help to solve the problem.

Thanks

2 REPLIES 2

New Contributor

I have the same problem. Have you solved it

Community Manager

@xoe as this is an older post, you would have a better chance of receiving a resolution by starting a new thread. This will also be an opportunity to provide details specific to your environment that could aid others in assisting you with a more accurate answer to your question. You can link this thread as a reference in your new post.



Regards,

Vidya Sargur,
Community Manager


Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.
Learn more about the Cloudera Community: