Support Questions
Find answers, ask questions, and share your expertise

File previview stop working ....

New Contributor

Hello, for some days the preview file window can't show the file content and stay desperately empty ... The only log i have found is into the /var/log/ambari-server/files-view/files-view.log file and it's not very explicit... :

17 Oct 2016 12:49:39,757 ERROR [ambari-client-thread-106] [FILES 
1.0.0 FILE_2] FilePreviewService:96 - Error occurred while previewing 
/user/svy/matisse/dt=2016-10-17/matisse-09.log :

Nothing more after ":" !

And if i try to download the file :

{
  "status": 500,
  "message": "Server Error"
}

For my opinion, it's not an HDFS trouble because by HDFS Web UI i can download this file without any error. And it's not a one file trouble because i reproduce this error in any files on my HDFS cluster. Thank in advance for your help

3 REPLIES 3

Explorer

It seems like certain parameters are missed in the configuration. Can u try creating one more instance of the view. and see The Logs. If nothing is working for You May be the Corrupted file_view.jar. Replace it with Healthy jar in /var/lib/ambari-server/resources/views/

@stephane verdy

Can you please paste more logs here and the screenshot of the error you see from Ambari UI while loading File View?

Can you try creating one more file view and check if that works.

Login to AmbariUI->admin->Manage Ambari->Views->FILES View-> Create New Instance

New Contributor

Hello,

I also had this issue, using ambariview and KMS + HDFS.

This 500 message comes in fact from a 403 message answered by KMS, stating that the user ambari is not allowed to impersonate the end-user.

In that case, you need to add in the custom kms-site configuration :

hadoop.proxyuser.ambari.users=*          (your ambari instance uses the unix ambari account)
		hadoop.proxyuser.ambari.groups=*
	
		hadoop.proxyuser.ambari.hosts=*
	

restart KMS.

"403" KMS' answer is gone.

so is the 500 error.