Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

GEtting error ubuntu while upgrade ambari from 2.4 to 2.6

Highlighted

GEtting error ubuntu while upgrade ambari from 2.4 to 2.6

New Contributor

Ambari upgrade on ubuntu 14

step 1

Create the database backups.


step 4

on is server machine

:/# ambari-server status

/# ambari-server stop

Create a backup of the Ambari Server meta info.

#cd /var/tmp

#mkdir dbdumps

#cd dbdumps

OR

Give above path for back up or follow default path for backup procedure

# mkdir /var/run/ambari-server/bootstrap/

# chmod 777 /var/run/ambari-server/bootstrap/

# ambari-server backup

Zip file created at /var/lib/ambari-server/Ambari_State_Backup.zip

Backup complete.

Ambari Server 'backup' completed successfully.

Login to hosts

# ambari agent stop


step 5

For Ubuntu 14:

on server machine

#wget -O /etc/apt/sources.list.d/ambari.list http://public-repo-1.hortonworks.com/ambari/ubuntu14/2.x/updates/2.6.1.3/ambari.list

#apt-key adv --recv-keys --keyserver keyserver.ubuntu.com B9733A7A07513CAD

#apt-get update

Confirm that Ambari packages downloaded successfully by checking the package name list.

#apt-cache showpkg ambari-server

#apt-cache showpkg ambari-agent

#apt-cache showpkg ambari-metrics-assembly

# apt-cache show ambari-server | grep Version

Version: 2.6.1.3-3

Version: 2.4.0.1-1

#apt-get install ambari-server

ON other agent machines

#wget -O /etc/apt/sources.list.d/ambari.list http://public-repo-1.hortonworks.com/ambari/ubuntu14/2.x/updates/2.6.1.3/ambari.list

#apt-get update

#apt-get upgrade ambari-agent

#amabri-server restore

#ambari-server restart

If fails

root@v-pt-0c65:/# ambari-server setup

#ambari-server restart

getting error after restart in log file as shown below

/var/lib/ambari-server/resources/stacks/HDP/2.6/role_command_order.json

23 Feb 2018 01:45:57,304 ERROR [main] ModuleFileUnmarshaller:141 - Cannot parse /var/lib/ambari-server/resources/stacks/HDP/2.5/upgrades/nonrolling-upgrade-2.5.xml

23 Feb 2018 01:45:57,306 ERROR [main] ModuleFileUnmarshaller:143 - Upgrade pack must contain pre-downgrade elements if pre-upgrade exists for processing component RANGER/RANGER_ADMIN

java.lang.RuntimeException: Upgrade pack must contain pre-downgrade elements if pre-upgrade exists for processing component RANGER/RANGER_ADMIN

at org.apache.ambari.server.state.stack.UpgradePack$ProcessingComponent.afterUnmarshal(UpgradePack.java:565)


Don't have an account?
Coming from Hortonworks? Activate your account here