Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

GLIBCXX_3.4.11 on SLES 11.1

Solved Go to solution

GLIBCXX_3.4.11 on SLES 11.1

New Contributor

my cloudera installation fails because it cannot find libstdc++.so.6, even though i can look for it under /usr/lib/libstdc++.so.6. 

 

anyone know how to get pass this error?

 

zypper --gpg-auto-import-keys -n in impala
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides libstdc++.so.6(GLIBCXX_3.4.11)(64bit) needed by impala-1.1.1-1.p0.21.sles11.x86_64
Solution 1: do not ask to install a solvable providing impala
Solution 2: break impala by ignoring some of its dependencies

1 ACCEPTED SOLUTION

Accepted Solutions

Re: GLIBCXX_3.4.11 on SLES 11.1

Master Collaborator
Could you also post the output of `zypper search libstdc++`. I'm able to run Impala on SLES SP1, and I have libstdc++45. It's possible you have an older version installed and Impala is requiring the latest one.
4 REPLIES 4

Re: GLIBCXX_3.4.11 on SLES 11.1

Master Collaborator

What does the following command return on your system?

 

ldd /usr/lib/libstdc++.so.6

 

Also, are you on a 64-bit OS?

Re: GLIBCXX_3.4.11 on SLES 11.1

Master Collaborator
Could you also post the output of `zypper search libstdc++`. I'm able to run Impala on SLES SP1, and I have libstdc++45. It's possible you have an older version installed and Impala is requiring the latest one.

Re: GLIBCXX_3.4.11 on SLES 11.1

New Contributor
i think this may be the problem. i only have libstdc++43 on my system. will try to upgrade it and try again.

Re: GLIBCXX_3.4.11 on SLES 11.1

Master Collaborator
Let us know how that goes - I hope it works for you. Note that this is not a "package upgrade" in the strictest sense. libstdc++43 and libstdc++45 can both be installed at the same time (they both are on my machine) - so you won't be upgrading libstdc++43, you'll just be installing libstdc++45 as well.