Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

GRAFANA quick link UI not owrking

Highlighted

GRAFANA quick link UI not owrking

Explorer

HI Team,

I have not changed any configuration after i install grafana. Grafana service up and running.. But quick view display just blank. no Hbase and hive details are listed. i got the below message from the error log

When I try the admin:admin login, the following appears in /var/log/grafana/grafana.log: 2016/06/13 12:42:32 [login.go:99 LoginPost()] [E] Invalid username or password: Invalid Username or Password 2016/06/13 12:42:32 [I] Completed 127.0.0.1 - "POST /login HTTP/1.1" 401 Unauthorized 42 bytes in 54519us 2016/06/13 12:42:32 [I] Completed 127.0.0.1 - "GET /api/login/ping HTTP/1.1" 401 Unauthorized 26 bytes in 438us

7 REPLIES 7
Highlighted

Re: GRAFANA quick link UI not owrking

Super Mentor

@suresh krish

Looks like Grafana Password issue. As we see:

Invalid username or password: Invalid Username or Password

Can you pelase try resetting the grafana password:

https://community.hortonworks.com/content/supportkb/49508/how-to-change-grafana-admin-password-when-...

.

Highlighted

Re: GRAFANA quick link UI not owrking

Explorer

do i need to check any configuration ? I can able to login as a admin/admin

Highlighted

Re: GRAFANA quick link UI not owrking

Super Collaborator

@suresh krish

It looks that admin password is changed. You can try to reset this back to default, please refer below article for procedure.

https://community.hortonworks.com/content/supportkb/49508/how-to-change-grafana-admin-password-when-...

Highlighted

Re: GRAFANA quick link UI not owrking

Explorer

do i need to check any configuration ? I can able to login as a admin/admin

Re: GRAFANA quick link UI not owrking

Explorer

BU i can login to grafana UI using admin/admin credientials.. but i see blank secreen.. Just DASHBOARD letter i see

Highlighted

Re: GRAFANA quick link UI not owrking

Super Mentor

suresh krish

In order to troubleshoot please check the "Java Script Debugger tool" like in Chrome:

Menu --> More Tools --> Developer Tools.

Above will show what kind of error is causing the blank page dashboard.

However it will be best to try resetting the password again.

By any chance are you using LDAP users in grafana? or is it the default.

Highlighted

Re: GRAFANA quick link UI not owrking

Expert Contributor

@suresh krish

Did you try restarting Grafana?

Can you check the value of ams-grafana-env:metrics_grafana_password in Ambari?

Don't have an account?
Coming from Hortonworks? Activate your account here