Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Getting a warning while installing,warning message related to Derby

Getting a warning while installing,warning message related to Derby

I have almost kept most of the settings as default while setting up the ambari server steps. After the Assigning master, Assigning slaves and clients stepswhile proceeding with the Customizing services step when I click to proceed further, I get the following warning message. Can you suggest something for this?

Warning

Derby is not recommended for production use. With Derby, Oozie Server HA and concurrent connection support will not be available.

In the Oozie server configuration i have kept the default selection the way it is as Oozie Database to be as New Derby Database.

Has this to be changed? if yes den which one should I go for? I get the following options to choose from:

New Derby Database

Existing MySQL Database, Existing PostgreSQL Database, Existing Oracle Database, Existing SQL Anywhere Database

3 REPLIES 3
Highlighted

Re: Getting a warning while installing,warning message related to Derby

Highlighted

Re: Getting a warning while installing,warning message related to Derby

Mentor
@Kunal Gaikwad

it is an informative message saying if this is a production cluster, we don't recommend Derby and choose other flavors. I wouldn't worry about it if you're just testing.

Highlighted

Re: Getting a warning while installing,warning message related to Derby

@Kunal Gaikwad you can view the Derby database as similar to something like SQL Express which is useful as a lightweight data store but limited in a production capacity due to lack of Enterprise features.

Don't have an account?
Coming from Hortonworks? Activate your account here