Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Getting error while installing Ambari

Getting error while installing Ambari

New Contributor

I am trying to install Ambari server on Redhat 6.7 i am getting this error.

<yum -y install ambari-server Loaded plugins: product-id, security, subscription-manager This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register. Setting up Install Process Updates-ambari-2.0.0 | 2.8 kB 00:00 http://public-repo-1.hortonworks.com/ambari/centos6/2.x/updates/2.0.0/repodata/repomd.xml: [Errno -1] Error importing repomd.xml for Updates-ambari-2.0.0: Damaged repomd.xml file Trying other mirror. Error: Cannot retrieve repository metadata (repomd.xml) for repository: Updates-ambari-2.0.0. Please verify its path and try again/>

5 REPLIES 5

Re: Getting error while installing Ambari

@Tajinderpal Singh

Can you make sure your DNS is working properly? Do 'yum clean all' and cross check downloading any since package manually.

It might be the case your proxy server has a stale partially retrieved copy or just refuses to give a good one.

Please refer below link -https://www.centos.org/forums/viewtopic.php?t=21633

Re: Getting error while installing Ambari

I was able to download the file successfully -

9499-screen-shot-2016-11-16-at-65442-pm.png

Re: Getting error while installing Ambari

New Contributor

I am also able to download repomd.xml but my issue is after downloading ambari.repo file i am not able to install it.

wget http://public-repo-1.hortonworks.com/ambari/centos6/2.x/updates/2.0.0/ambari.repo

[root@env26-node5 yum.repos.d]# yum -y install ambari-server
Loaded plugins: product-id, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Setting up Install Process
Updates-ambari-2.0.0                                                                                                    | 2.8 kB     00:00    
http://public-repo-1.hortonworks.com/ambari/centos6/2.x/updates/2.0.0/repodata/repomd.xml: [Errno -1] Error importing repomd.xml for Updates-ambari-2.0.0: Damaged repomd.xml file
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: Updates-ambari-2.0.0. Please verify its path and try again

Re: Getting error while installing Ambari

@Tajinderpal Singh

This is an issue with RedHat Subscription Manager, Please contact your server team to register with RHEL and resolve this issue.

Can you even provide me the output of

yum -v -y install ambari-server

Even can you please check are you able to run 'yum update'?

Hope this helps you.

Re: Getting error while installing Ambari

Contributor
@Tajinderpal Singh

You can register the rhn systame by running rhn_register