Support Questions
Find answers, ask questions, and share your expertise

Getting error while starting time line server.

HDP version 2.5.3.

Amabri version 2.4.1

After installing spark 2.0 getting error while restarting time line server.:-

FATAL applicationhistoryservice.ApplicationHistoryServer (ApplicationHistoryServer.java:launchAppHistoryServer(177)) - Error starting ApplicationHistoryServer java.lang.RuntimeException: No class defined for org.apache.spark.deploy.history.yarn.plugin.SparkATSPlugin

4 REPLIES 4

Mentor

Already gone through following link:-s https://community.hortonworks.com/questions/8682/spark-history-server-startup-error.html

But didn't work for me.

Hi @Ashnee Sharma, Were you able to solve the problem? I am getting the same error. and the URL posted isn't working for me as well.

Thanks

Atul Aggarwal

Expert Contributor

@Ashnee Sharma @Atul Aggarwal

I think the issue is that you didn't have your App timeline server on the same machine as your Resource Manager. I ran into this issue the other day and happened to stumble across this thread. Hope this helps anyone else that runs into it.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.