Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Getting errors while adding segments to a running HAWQ cluster through Ambari

Getting errors while adding segments to a running HAWQ cluster through Ambari

New Contributor

I'm not able to add new HAWQ segments to an already existing HAWQ clutser. I'm getting the below error:

call['conf-select create-conf-dir --package hadoop --stack-version 2.4.0.0-169 --conf-version 0'] {'logoutput': False, 'sudo': True, 'quiet': False, 'stderr': -1}
2016-11-17 03:00:33,595 - call returned (1, '/etc/hadoop/2.4.0.0-169/0 exist already', '')

When I try to run the command "/usr/bin/yum --verbose -d 0 -e 0 -y install hawq" manually on the host on which I want to add the HAWQ segment, I'm getting the below error:

[root@kvs-in-merlin08 ~]# /usr/bin/yum --verbose -d 0 -e 0 -y install hawq
Not loading "rhnplugin" plugin, as it is disabled
Loading "product-id" plugin
Loading "subscription-manager" plugin
Updating Subscription Management repositories.
Config time: 4.911
Yum version: 3.4.3
rpmdb time: 0.000
Setting up Package Sacks
pkgsack time: 0.022
Checking for virtual provide or file-provide for hawq
No package hawq available.
Error: Nothing to do


I've also attached the errors which I encountered while adding the HAWQ segment component to the newly added hosts to our hortonworks cluster.<a href="/storage/attachments/9547-hawq-segment-error.txt">hawq-segment-error.txt</a>

Given below is the version information:

Apache Ambari Version - 2.2.1.0

HDP Version - HDP-2.4.0.0-169

HAWQ Version - HAWQ version 2.0.0.0_beta build 21030

1 REPLY 1

Re: Getting errors while adding segments to a running HAWQ cluster through Ambari

Cloudera Employee

Hello,

It appears HAWQ is not available in the repositories you have configured. I would check the output of the command:

yum repolist

Make sure you have a HDB repository setup, and if not set it up using the correct version.

Regards,

Adam

Don't have an account?
Coming from Hortonworks? Activate your account here