Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Grafana quick link UI is giving ERR_SSL_PROTOCOL_ERROR error.

Solved Go to solution
Highlighted

Grafana quick link UI is giving ERR_SSL_PROTOCOL_ERROR error.

Contributor

when i click on grafana UI then it will take me to the a different page and there its giving

This site can’t provide a secure connection

<hostname> sent an invalid response.

ERR_SSL_PROTOCOL_ERROR

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Grafana quick link UI is giving ERR_SSL_PROTOCOL_ERROR error.

Super Mentor

@Yukti Agrawal

Can you please try the following to see if it fixes your issue?

1. Edit /etc/ambari-server/conf/ambari.properties to set the empty values:

http.strict-transport-security=
views.http.strict-transport-security=

2. Restart ambari server

ambari-server restart

3. Clear the browsers cache (or for testing open the browser in "Incognito mode") then access the grafana UI. Please have a look at the HSTS setting of browsers : http://classically.me/blogs/how-clear-hsts-settings-major-browsers

.

12 REPLIES 12

Re: Grafana quick link UI is giving ERR_SSL_PROTOCOL_ERROR error.

Super Mentor
@Yukti Agrawal

- By any chance have you added "https" instead of "http" in your "Advanced ams-grafana-ini" for the "protocol" field?

Re: Grafana quick link UI is giving ERR_SSL_PROTOCOL_ERROR error.

Contributor

[server]

# Protocol (http or https)

;protocol = http

protocol = http

# The ip address to bind to, empty will bind to all interfaces

;http_addr =

# The http port to use

;http_port = 3000 http_port = 3000

# The public facing domain name used to access grafana from a browser

;domain = localhost

Re: Grafana quick link UI is giving ERR_SSL_PROTOCOL_ERROR error.

Super Mentor

@Yukti Agrawal

Are you facing this issue with some specific browser like "Google Chrome" ? Or have you tried with other browsers as well? Sometimes this kind of issue might happen due to browser setting as well like:

http://stackoverflow.com/questions/25277457/google-chrome-redirecting-localhost-to-https

Re: Grafana quick link UI is giving ERR_SSL_PROTOCOL_ERROR error.

Super Mentor

@Yukti Agrawal

It will be great if you can share the output of the following command :

# cd /var/log/ambari-metrics-grafana

# grep 'Listen' grafana.log
2017/02/22 12:34:04 [I] Listen: http://0.0.0.0:3000

# grep 'Listen' grafana.out 
2017/02/22 14:09:44 [I] Listen: http://0.0.0.0:3000

.

Re: Grafana quick link UI is giving ERR_SSL_PROTOCOL_ERROR error.

Contributor

$ grep 'Listen' grafana.log

2017/02/22 07:14:40 [I] Listen: http://0.0.0.0:3000

2017/02/22 09:29:05 [I] Listen: http://0.0.0.0:3000

2017/02/22 09:31:09 [I] Listen: http://0.0.0.0:3000

$ grep 'Listen' grafana.out

2017/02/22 09:31:09 [I] Listen: http://0.0.0.0:3000

Re: Grafana quick link UI is giving ERR_SSL_PROTOCOL_ERROR error.

Contributor

one thing i want to clear here is:

https://<localhost>:8443 --- my ambari address

And when i click on Grafana UI link its:

https://<localhost>:3000

Re: Grafana quick link UI is giving ERR_SSL_PROTOCOL_ERROR error.

Super Mentor

@Yukti Agrawal

Which version of ambari is it?

Re: Grafana quick link UI is giving ERR_SSL_PROTOCOL_ERROR error.

Contributor

Its 2.2.2.3

Re: Grafana quick link UI is giving ERR_SSL_PROTOCOL_ERROR error.

Super Mentor

@Yukti Agrawal

I will check why is it happening .. at my lab with similar setup.

In the mean time as a quick workaround you might want to setup HTTPs for Grafana which is quite easy.

https://docs.hortonworks.com/HDPDocuments/Ambari-2.4.2.0/bk_ambari-user-guide/content/setup_https_fo...