Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

HA is not working in case of 2 Datanode and 1 HRegion failure.

Solved Go to solution

HA is not working in case of 2 Datanode and 1 HRegion failure.

New Contributor

I tried to do HA test of HDFS as shutting down 2 datanode(among 3) and 1 region server(among 3). After shutting down, I could not access and write data at all using remaining 1 datanode and 2 Hregion. I like to know whether it is general work or I missed something. Please find the attached about system diagram.

74529-screenshot277.jpg

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: HA is not working in case of 2 Datanode and 1 HRegion failure.

New Contributor

Thank you @Sridhar,

I did shut down using Ambari, so I think I did graceful shutdown. I think three is minimum for datanode and I like to make sure it is working alone.

View solution in original post

2 REPLIES 2
Highlighted

Re: HA is not working in case of 2 Datanode and 1 HRegion failure.

@SH Kim

Did you try to do a graceful shutdown of region servers and Datanodes decommissioning? as you are using very less number of nodes, always it better to have more than 50% availability.

Highlighted

Re: HA is not working in case of 2 Datanode and 1 HRegion failure.

New Contributor

Thank you @Sridhar,

I did shut down using Ambari, so I think I did graceful shutdown. I think three is minimum for datanode and I like to make sure it is working alone.

View solution in original post

Don't have an account?
Coming from Hortonworks? Activate your account here