Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

HBase doesn't start when Sandbox is started under Docker on Mac

HBase doesn't start when Sandbox is started under Docker on Mac

New Contributor

Started Sandbox under Docker using instructions given at: http://hortonworks.com/hadoop-tutorial/hortonworks-sandbox-guide/#section_4

I am using Mac OS. Everything worked fine - except...

  1. http://sandbox.hortonworks.com:8888/ didn't work, but http://localhost:8888/ worked.
  2. http://localhost:8080/ also worked.
  3. Under 'HBase' -> 'Service Actions', clicked on 'Start'. After long time, it showed 100% completed in green. But in Ambari, HBase Master is still in 'Stopped' state & under 'RegionServers', I see 0/1 alive.

What am I doing wrong? Please help. Thanks.

19 REPLIES 19

Re: HBase doesn't start when Sandbox is started under Docker on Mac

Please check regionserver and master logs for errors under /var/log/hbase

Re: HBase doesn't start when Sandbox is started under Docker on Mac

New Contributor

Only error messages I see are: ./hbase-hbase-master-sandbox.hortonworks.com.log:2016-11-27 06:45:12,113 INFO [main-SendThread(sandbox.hortonworks.com:2181)] zookeeper.ClientCnxn: Opening socket connection to server sandbox.hortonworks.com/172.17.0.2:2181. Will not attempt to authenticate using SASL (unknown error)

./hbase-hbase-master-sandbox.hortonworks.com.log:2016-11-28 00:55:56,113 ERROR [Thread-75] util.PolicyRefresher: PolicyRefresher(serviceName=Sandbox_hbase): failed to refresh policies. Will continue to use last known version of policies (6)

Re: HBase doesn't start when Sandbox is started under Docker on Mac

Have you checked that your zookeeper is running? is there any error in zookeeper logs?

Re: HBase doesn't start when Sandbox is started under Docker on Mac

New Contributor

Zookeeper is all green. The errors look harmless..

2016-11-28 00:47:44,855 - ERROR [main:QuorumPeerConfig@287] - Invalid configuration, only one server specified (ignoring)

2016-11-28 00:56:28,775 - ERROR [SyncThread:0:NIOServerCnxn@178] - Unexpected Exception:

java.nio.channels.CancelledKeyException

at sun.nio.ch.SelectionKeyImpl.ensureValid(SelectionKeyImpl.java:73)

Re: HBase doesn't start when Sandbox is started under Docker on Mac

can you remove all entries from /etc/hosts except the below one and restart all the services(zookeeper,hbase,regionservers,datanode,namenode...)

127.0.0.1       localhost

Re: HBase doesn't start when Sandbox is started under Docker on Mac

New Contributor

Followed the steps given below. Still HBase is not starting...

  • docker stop sandbox
  • ./start_sandbox.sh
  • ssh root@sandbox.hortonworks.com -p 2222
  • vi /etc/hosts
  • deleted all lines except 127.0.0.1 localhost
  • Stopped ZooKeeper (Got green)
  • Started ZooKeeper (Got green)
  • Restarted Hdfs (Got green)
  • Confirmed hdfs was working: hadoop fs -ls /
  • Clicked on 'Start' under 'HBase'. After a long time it said 100% in Green, but HBase isn't started.

Re: HBase doesn't start when Sandbox is started under Docker on Mac

New Contributor

Also see this... 2016-11-28T07:26:27.780+0000: 12.563: [GC (Allocation Failure) 2016-11-28T07:26:27.863+0000: 12.646: [ParNew: 163840K->15066K(184320K), 0.1689593 secs] 163840K->15066K(1028096K), 0.2747327 secs] [Times: user=0.04 sys=0.02, real=0.28 secs]

Do I need to give it more memory? If yes, where can I change memory configurations?

Re: HBase doesn't start when Sandbox is started under Docker on Mac

I think this GC logs are fine.

Re: HBase doesn't start when Sandbox is started under Docker on Mac

New Contributor

So no one is running into these type of issues on Mac?

Don't have an account?
Coming from Hortonworks? Activate your account here