Support Questions
Find answers, ask questions, and share your expertise

HDC cloud failed on WaitCondition

Expert Contributor

I am trying to launch HDC cloud on AWS. I tried 3/4 times and it has been failing consistently.

  • Using existing VPC and subnet
  • Using existing RDS
  • Using existing key/value pair.
  • It launches the initial instance on the EC2 but I was unable to login to that instance to see logs. It waits for 10 hours and fails.
    "InstanceWaitCondition" : {
       "Type" : "AWS::CloudFormation::WaitCondition",
       "DependsOn" : "Cloudbreak",
       "Properties" : {
          "Handle"  : { "Ref" : "InstanceWaitHandle" },
          "Timeout" : 36000

I am not sure how to debug the problem and find the root cause to fix the problem. Any input is highly appreciated.



For public gateway, it has to be added to the routing table. Check your routing tables and see if it exists (probably won't be created by the template if using an existing VPC). Please see this page in AWS documentation section "Enabling Internet Access":

Other things that may help:

Egress only gateway:

DNS resolution:


@Anandha L Ranganathan You can find the CF template on the Cloudformation view if you select a stack and choose the template tab. Just to be sure: Did you try to launch instances in the same vpc / subnet as the instances launched by the cloudbreak? From these instances were you able to telnet to RDS instances? Were you able to ping external world and other aws instances in the same vpc / subnet?


It looks like there is definitely a routing issue and/or a network ACL that needs to be added or changed. It may be good place to look at AWS support on why hosts from subnet to subnet are having trouble communicating. I’ve run into situations in AWS when manually setting up services to talk to EMR clusters. Once that is found, find out how to set this in your template for future use (I am not that familiar with configuring the templates yet).

@Anandha L Ranganathan Were you able to resolve the issue? I see in the other post that you managed to get to the create cluster stage? What did you do to solve the problem?

Expert Contributor

@Dominika Bialek Still I am unable to launch cloudbreak in Oregon region. I was able to successfully launch cloudbreak in Virginia. But our Virginia region doesn't have proper VPC and subnet setup. In Oregon region, we are multiple subnets (application, public, and mgmt ). I tried in all three subnets but failed to install cloudbreak. We had checked other systems in the region/ availability zone side by side and everything looks similar and we haven't found any differences between the instances launched by cloudbreak and our systems. I checked with our IT security team and everything looks good in the routing table, subnet, and other components. We couldn't figure out the problem.