Support Questions

Find answers, ask questions, and share your expertise

HDF minor upgrade to


I'm a bit confused about how to upgrade my HDF stack from to the recent patch release

The Ambari itself is already the latest version (2.5.1)

I've already upgraded the Management Pack on the Amabri server node to the latest version ( But I don't see an entry for HDF- version from the dropdown list on the Admin -> Versions page.

How should I register the new version to be able to do this upgrade? Do I need to upload a "Version Definition File"?



Hi @Alireza Sadeghi.

I think I've seen this issue before. Two things you can try: 1) restart Ambari and 2) refresh your browser cache.


Hi @Andrew Lim

I tried both, but the new version is still not appearing.


@Alireza Sadeghi, unless somebody responds with a solution, when I get a chance I will see if I can reproduce your issue with the Mpack.


Hi @Alireza Sadeghi

The suggestions I had earlier to fix the version not appearing was when I performed an initial HDF install via Ambari not an upgrade.

I just attempted an upgrade from HDF 3.0.0 to HDF and was able to reproduce your issue. When doing an upgrade you need to register the version you are upgrading to as described here:

Here is the basic process:

  1. Admin-->Manage Ambari
  2. Select "Versions"
  3. Select "Register Versions"


  4. Select "HDF-3.0" from the list. Enter the extension in the Name field ie. HDF- For your OS, add the proper HDF- base URL (for my CentOS7 enviro, it was: Save.


  5. Select Install. Then select Upgrade.
  6. You will be presented with upgrade options: Rolling Upgrade and Express Upgrade


  7. I went with Express Upgrade which had a couple minor issues to resolve before initiating (need to disable Auto-Start and perform some checks on NiFi and ZooKeeper). Once resolved, I was able to proceed with the Express Upgrade.
  8. You get some prompts whether to proceed or not based on warnings, etc.




Hi @Alireza Sadeghi,

Did this solve your issue? Just wanted this marked as an accepted answer if so. Otherwise, can try to provide further troubleshooting. Thanks!