Support Questions
Find answers, ask questions, and share your expertise

HDF upgrade Bad request received: repo_name is required to verify repository

HDF upgrade Bad request received: repo_name is required to verify repository

Explorer

Hello,

I try to upgrade HDF from HDF-2.1.1.0 to HDF-3.1.2.0-7

After upgraded ambari-server, and when I add version with Ambari IHM and set the Repositories of redhat6 and save.

Then, the button install is disabled(picture1)

We use a custome remo in our servers : My hdf.repo

[HDF-2.1.1.0]
name=HDF Version - HDF-2.1.1.0
baseurl=http://inbdfops01***/HDF/centos6/2.x/updates/2.1.1.0
gpgcheck=1
gpgkey=http://inbdfops01***/HDF/centos6/2.x/updates/2.1.1.0/RPM-GPG-KEY/RPM-GPG-KEY-Jenkins
enabled=1
priority=1

[HDP-UTILS-1.1.0.21]
name=HDP-UTILS Version - HDP-UTILS-1.1.0.21
baseurl=http://inbdfops01***/HDP-UTILS-1.1.0.21
gpgcheck=1
gpgkey=http://inbdfops01***/HDF/centos6/2.x/updates/2.1.0.0/RPM-GPG-KEY/RPM-GPG-KEY-Jenkins
enabled=1
priority=1

#VERSION_NUMBER=3.1.2.0-7
[HDF-3.1.2.0-7]
name=HDF Version - HDF-3.1.2.0
baseurl=http://inbdfops01***/HDF/centos6/3.x/updates/3.1.2.0-7
gpgcheck=1
gpgkey=http://inbdfops01***/HDF/centos6/3.x/updates/3.1.2.0-7/RPM-GPG-KEY/RPM-GPG-KEY-Jenkins
enabled=1
priority=1

[HDP-UTILS-1.1.0.22]
name=Hortonworks Data Platform Utils Version - HDP-UTILS-1.1.0.22
baseurl=http://inbdfops01***/HDP-UTILS-1.1.0.22/centos6
gpgcheck=0
enabled=1
priority=1

In the server inbdfops, I got all data repo:

repository/HDP-UTILS-1.1.0.22/centos6

-rw-r--r-- 1 root root  197 May 29 08:43 hdp-utils.repo
drwxr-xr-x 2 root root 4096 May 29 08:43 openblas
drwxr-xr-x 2 root root 4096 Jul 13 13:06 repodata
drwxr-xr-x 2 root root 4096 May 29 08:43 RPM-GPG-KEY
drwxr-xr-x 2 root root 4096 May 29 08:43 snappy

repository/HDF/centos6/3.x/updates/3.1.2.0-7

-rw-r--r--  1 root root 5502 Jun  1 19:11 artifacts.txt
-rw-r--r--  1 root root  559 Jun  1 19:11 build.id
-rw-r--r--  1 root root 3321 Jun  1 19:11 build_metadata.txt
-rw-r--r--  1 root root 2369 Jun  1 19:12 HDF-3.1.2.0-7-MAINT.xml
-rw-r--r--  1 root root 1677 Jun  1 19:12 HDF-3.1.2.0-7.xml
-rw-r--r--  1 root root  573 Jul 13 11:34 hdf.repo
drwxr-xr-x  2 root root 4096 Jun  1 19:12 hdf-select
-rw-r--r--  1 root root  496 Jun  1 19:11 hotfix_index.html
-rw-r--r--  1 root root  501 Jun  1 19:11 index.html
drwxr-xr-x  2 root root 4096 Jun  1 19:13 kafka
drwxr-xr-x  2 root root 4096 Jun  1 19:13 nifi
drwxr-xr-x  2 root root 4096 Jun  1 19:13 nifi_registry
-rw-r--r--  1 root root  494 Jun  1 19:11 private_index.html
-rw-r--r--  1 root root  493 Jun  1 19:11 public_index.html
drwxr-xr-x  2 root root 4096 Jun  1 19:13 ranger
drwxr-xr-x  2 root root 4096 Jun  1 19:13 registry
drwxr-xr-x  2 root root 4096 Jun  1 19:13 repodata
drwxr-xr-x  2 root root 4096 Jun  1 19:12 RPM-GPG-KEY
drwxr-xr-x  2 root root 4096 Jun  1 19:13 storm
drwxr-xr-x  2 root root 4096 Jun  1 19:13 streamline
drwxr-xr-x  2 root root 4096 Jul  5 11:55 tars
drwxr-xr-x 10 root root 4096 Jun  1 19:12 vrpms
drwxr-xr-x  2 root root 4096 Jun  1 19:14 zookeeper

And finally, I got this error in ambari_server.log

13 Jul 2018 13:45:11,989 ERROR [ambari-client-thread-25] BaseManagementHandler:67 - Bad request received: repo_name is required to verify repository
13 Jul 2018 13:45:11,989 ERROR [ambari-client-thread-26] BaseManagementHandler:67 - Bad request received: repo_name is required to verify repository

Any ideas how I can fix this error ?

Regards


sans-titre.png