Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

HDP 2.5 Ambari failed to add Accumulo service

avatar
Explorer

When adding Accumulo service using Ambari, it failed to start with the following message, also the version of accumulo seems odd as well:

File "/usr/lib/python2.6/site-packages/resource_management/core/source.py", line 75, in get_content
    raise Fail("{0} Source file {1} is not found".format(repr(self), path))
resource_management.core.exceptions.Fail: StaticFile('accumulo-metrics.xml') Source file /var/lib/ambari-agent/cache/common-services/ACCUMULO/1.6.1.2.2.0/package/files/accumulo-metrics.xml is not found
1 ACCEPTED SOLUTION

avatar
Explorer
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
9 REPLIES 9

avatar
Super Guru

The path is just an artifact of when Accumulo was first added to Ambari (HDP-2.2.0). The files that are common to all versions of Accumulo can live in that common-services directory. I think that is a red-herring.

https://github.com/apache/ambari/blob/2ad42074f1633c5c6f56cf979bdaa49440457566/ambari-server/src/mai...

Perhaps it is something trivial like you do not have the ambari-agent installed on the node in question (or maybe the wrong version of the ambari-agent)? I don't recall seeing this one before.

avatar
Explorer

The Ambari version is 2.4.0.0 and ambari-agent version is 2.4.0.0-1225.x86_64 and is running (same version as ambari-server).

avatar
Explorer

Could this be an Ambari issue (instead of Accumulo)? Has anyone tried to add and install Accumulo on HDP 2.5 sandbox successfully?

avatar
Super Guru

It's possible. I certainly don't know from the Accumulo side why this would be failing. I can say that Accumulo deploys just fine via Ambari on HDP 2.5.

Maybe the mighty @Robert Levas has a tip/suggestion?

avatar
Master Mentor

Can you check your repo? It's pointing to HDP 2.2 for some reason, also, highly recommend installing Ambari 2.4.2, with 2.4.0.0 there were many bugs.

avatar
Explorer

I am sorry if I did not make it clear that what I am dealing with is HDP 2.5 Sandbox VMWare image. The VM has been loaded with Ambari 2.4.0.0 already, but not with Accumulo.

avatar
Master Mentor

@Ruey Chang I will let the Sandbox team know but you are correct and we clearly stated that in our release notes for Sandbox http://hortonworks.com/hadoop-tutorial/hortonworks-sandbox-guide/#section_1

HDP Supported Components Not Installed These components are offered by the Hortonworks distribution, but not included in the Sandbox.

1. Apache Accumulo 2. Apache Mahout 3. Hue

avatar
Explorer

Thanks! Looking forward to have some answers.

avatar
Explorer
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login