Support Questions
Find answers, ask questions, and share your expertise
Announcements
Check out our newest addition to the community, the Cloudera Innovation Accelerator group hub.

HDP 2.6.1 Infra Solr Client Install fails "Source file /usr/lib/ambari-infra-solr-client/solrCloudCli.sh is not found"

Explorer

Hi, I'm installing HDP-2.6.1.0 on a RHEL 7.2 cluster (4 servers). I've configured a local repo for RHEL and Ambari like this:

HDP-2.6.1.0 HDP Version - HDP-2.6.1.0

HDP-UTILS-1.1.0.21 Hortonworks Data Platform Version - HDP-UTILS-1.1.0.21

ambari-2.5.1.0 ambari Version - ambari-2.5.1.0

mysql-community-server MySQL Community Server 5.7

repository redhat-sri "redhat cd"

repolist: 5,073

Followed installation steps, but installation of "Infra Solr Client" fails with error:

Traceback (most recent call last):
  File "/var/lib/ambari-agent/cache/common-services/AMBARI_INFRA/0.1.0/package/scripts/infra_solr_client.py", line 51, in <module>
    InfraSolrClient().execute()
  File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py", line 329, in execute
    method(env)
  File "/var/lib/ambari-agent/cache/common-services/AMBARI_INFRA/0.1.0/package/scripts/infra_solr_client.py", line 30, in install
    self.configure(env)
  File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py", line 119, in locking_configure
    original_configure(obj, *args, **kw)
  File "/var/lib/ambari-agent/cache/common-services/AMBARI_INFRA/0.1.0/package/scripts/infra_solr_client.py", line 35, in configure
    setup_infra_solr(name ='client')
  File "/var/lib/ambari-agent/cache/common-services/AMBARI_INFRA/0.1.0/package/scripts/setup_infra_solr.py", line 132, in setup_infra_solr
    solr_cloud_util.setup_solr_client(params.config)
  File "/usr/lib/python2.6/site-packages/resource_management/libraries/functions/solr_cloud_util.py", line 225, in setup_solr_client
    content=StaticFile(solrCliFilename)
  File "/usr/lib/python2.6/site-packages/resource_management/core/base.py", line 155, in __init__
    self.env.run()
  File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 160, in run
    self.run_action(resource, action)
  File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 124, in run_action
    provider_action()
  File "/usr/lib/python2.6/site-packages/resource_management/core/providers/system.py", line 123, in action_create
    content = self._get_content()
  File "/usr/lib/python2.6/site-packages/resource_management/core/providers/system.py", line 160, in _get_content
    return content()
  File "/usr/lib/python2.6/site-packages/resource_management/core/source.py", line 52, in __call__
    return self.get_content()
  File "/usr/lib/python2.6/site-packages/resource_management/core/source.py", line 76, in get_content
    raise Fail("{0} Source file {1} is not found".format(repr(self), path))
resource_management.core.exceptions.Fail: StaticFile('/usr/lib/ambari-infra-solr-client/solrCloudCli.sh') Source file /usr/lib/ambari-infra-solr-client/solrCloudCli.sh is not found

¿Anyone has faced the same problem?

6 REPLIES 6

Super Mentor

@Miguel Marquez

The following error usually occurs when the binaries of the components are not correctly/completely installed.

resource_management.core.exceptions.Fail: StaticFile('/usr/lib/ambari-infra-solr-client/solrCloudCli.sh') Source file /usr/lib/ambari-infra-solr-client/solrCloudCli.sh is not found

.

Please check you do not have any issue with your repositories access. Some of the files might be missed during installation and that might be causing the missing file.

.

Attempting to reinstall the ambari-infra components (specially client) will be advised. Manual "yum" command can be used.

Explorer

Hi Jay. Thanks for your answer. I've removed this component from installation, and now a similar problem occurs whith "Spark Client".

¿Do you have the line to install ambari-infra manually with yum (yum install ambari.....)?

Thanks for your time and support.

Super Mentor

@Miguel Marquez

If this issue is now occurring with different packages like Spark Client now. then the chances are very high that the Local Repo might be causing the issue or incomplete installation. Looking at the yum log might help.

.

The package name should be "ambari-infra-solr".

[root@sandbox ~]# yum info ambari-infra-solr


Installed Packages
Name        : ambari-infra-solr
Arch        : noarch
Version     : 2.5.0.5
Release     : 1
Size        : 208 M
Repo        : installed
From repo   : ambari-2.5.0.5-1
Summary     : Ambari Logsearch Assembly
URL         : http://www.apache.org
License     : (c) Apache Software Foundation
Description : Maven Recipe: RPM Package.

.

Explorer

Hi again @Jay SenSharma. I've checked the package installation, and is already installed in this node. Perhaps, ¿is this a problem with the python script that creates the configuration files for each component?

Thanks for your time.

Explorer

Hi @Jay SenSharma. Thanks for your support, you've guided me to finally find a solution. I did the following:

  1. Query for ambari rpm:

    rpm -qa | grep ambari
    	
    ambari-metrics-monitor-2.5.1.0-159.x86_64
    ambari-infra-solr-2.5.1.0-159.noarch
    ambari-infra-solr-client-2.5.1.0-159.noarch
    ambari-metrics-grafana-2.5.1.0-159.x86_64
    ambari-metrics-hadoop-sink-2.5.1.0-159.x86_64
    ambari-agent-2.5.1.0-159.x86_64
    	
  2. Removed ambari-infra-solr-client

    yum remove ambari-infra-solr-client
    	
    Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
    This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
    Resolving Dependencies
    There are unfinished transactions remaining. You might consider running yum-complete-transaction, or "yum-complete-transaction --cleanup-only" and "yum history redo last", first to finish them. If those don't work you'll have to try removing/installing packages by hand (maybe package-cleanup can help).
    --> Running transaction check
    ---> Package ambari-infra-solr-client.noarch 0:2.5.1.0-159 will be erased
    --> Finished Dependency Resolution
    Dependencies Resolved
    =======================================================================================================================
     Package                                Arch                 Version                     Repository               Size
    =======================================================================================================================
    Removing:
     ambari-infra-solr-client               noarch               2.5.1.0-159                 installed                25 M
    Transaction Summary
    =======================================================================================================================
    Remove  1 Package
    Installed size: 25 M
    Is this ok [y/N]: y
    Downloading packages:
    Running transaction check
    Running transaction test
    Transaction test succeeded
    Running transaction
      Erasing    : ambari-infra-solr-client-2.5.1.0-159.noarch                                                         1/1 
    warning: file /usr/lib/ambari-infra-solr-client/solrCloudCli.sh: remove failed: No such file or directory
    warning: file /usr/lib/ambari-infra-solr-client/log4j.properties: remove failed: No such file or directory
    warning: file /usr/lib/ambari-infra-solr-client/libs/zookeeper-3.4.6.jar: remove failed: No such file or directory
    warning: file /usr/lib/ambari-infra-solr-client/libs/woodstox-core-asl-4.4.1.jar: remove failed: No such file or directory
    warning: file /usr/lib/ambari-infra-solr-client/libs/utility-1.0.0.0-SNAPSHOT.jar: remove failed: No such file or directory
    warning: file /usr/lib/ambari-infra-solr-client/libs/tools-1.7.0.jar: remove failed: No such file or directory
    warning: file /usr/lib/ambari-infra-solr-client/libs/stax2-api-3.1.4.jar: remove failed: No such file or directory
    warning: file /usr/lib/ambari-infra-solr-client/libs/solr-solrj-5.5.2.jar: remove failed: No such file or directory
    warning: file /usr/lib/ambari-infra-solr-client/libs/slf4j-log4j12-1.7.2.jar: remove failed: No such file or directory
    warning: file /usr/lib/ambari-infra-solr-client/libs/slf4j-api-1.7.2.jar: remove failed: No such file or directory
    warning: file /usr/lib/ambari-infra-solr-client/libs/objenesis-2.2.jar: remove failed: No such file or directory
    warning: file /usr/lib/ambari-infra-solr-client/libs/noggit-0.6.jar: remove failed: No such file or directory
    warning: file /usr/lib/ambari-infra-solr-client/libs/log4j-1.2.17.jar: remove failed: No such file or directory
    warning: file /usr/lib/ambari-infra-solr-client/libs/junit-4.10.jar: remove failed: No such file or directory
    warning: file /usr/lib/ambari-infra-solr-client/libs/jcl-over-slf4j-1.7.7.jar: remove failed: No such file or directory
    warning: file /usr/lib/ambari-infra-solr-client/libs/jackson-mapper-asl-1.9.13.jar: remove failed: No such file or directory
    warning: file /usr/lib/ambari-infra-solr-client/libs/jackson-core-asl-1.9.9.jar: remove failed: No such file or directory
    warning: file /usr/lib/ambari-infra-solr-client/libs/httpmime-4.4.1.jar: remove failed: No such file or directory
    warning: file /usr/lib/ambari-infra-solr-client/libs/httpcore-4.4.1.jar: remove failed: No such file or directory
    warning: file /usr/lib/ambari-infra-solr-client/libs/httpclient-4.4.1.jar: remove failed: No such file or directory
    warning: file /usr/lib/ambari-infra-solr-client/libs/hamcrest-core-1.1.jar: remove failed: No such file or directory
    warning: file /usr/lib/ambari-infra-solr-client/libs/guava-16.0.jar: remove failed: No such file or directory
    warning: file /usr/lib/ambari-infra-solr-client/libs/easymock-3.4.jar: remove failed: No such file or directory
    warning: file /usr/lib/ambari-infra-solr-client/libs/commons-logging-1.1.1.jar: remove failed: No such file or directory
    warning: file /usr/lib/ambari-infra-solr-client/libs/commons-lang-2.5.jar: remove failed: No such file or directory
    warning: file /usr/lib/ambari-infra-solr-client/libs/commons-io-2.1.jar: remove failed: No such file or directory
    warning: file /usr/lib/ambari-infra-solr-client/libs/commons-collections-3.2.2.jar: remove failed: No such file or directory
    warning: file /usr/lib/ambari-infra-solr-client/libs/commons-codec-1.8.jar: remove failed: No such file or directory
    warning: file /usr/lib/ambari-infra-solr-client/libs/commons-cli-1.3.1.jar: remove failed: No such file or directory
    warning: file /usr/lib/ambari-infra-solr-client/libs/commons-beanutils-1.9.2.jar: remove failed: No such file or directory
    warning: file /usr/lib/ambari-infra-solr-client/libs/checkstyle-6.19.jar: remove failed: No such file or directory
    warning: file /usr/lib/ambari-infra-solr-client/libs/antlr4-runtime-4.5.3.jar: remove failed: No such file or directory
    warning: file /usr/lib/ambari-infra-solr-client/libs/antlr-2.7.7.jar: remove failed: No such file or directory
    warning: file /usr/lib/ambari-infra-solr-client/libs/ambari-logsearch-solr-client-2.5.1.0.159.jar: remove failed: No such file or directory
    warning: file /usr/lib/ambari-infra-solr-client/libs: remove failed: No such file or directory
      Verifying  : ambari-infra-solr-client-2.5.1.0-159.noarch                                                         1/1 
    Removed:
      ambari-infra-solr-client.noarch 0:2.5.1.0-159                                                                        
    Complete!
    	

    Here I've noticed: " warning: file /usr/lib/ambari-infra-solr-client/libs: remove failed: No such file or directory". That's really odd.

  3. Installed ambari infra client again:

    		yum install ambari-infra-solr-client
    	
    ....
    Installed: 
    	ambari-infra-solr-client.noarch 0:2.5.1.0-159
    Complete!
    	

After these steps, the ambari-infra installation via the web page shows a success message. Yes! Thanks for your time and support Hope this errors are reviewed and corrected in future releases.

New Contributor

Check log in /var/log/ambari-infra-solr/solr-install.log

If it says

-bash: /usr/lib/ambari-infra-solr/bin/solr: No such file or directory

cd into /usr/lib/ambari-infra-solr/ and check if all files are present if not run command

yum install ambari-infra-solr*

,

cd into /usr/lib/ambari-infra-solr

If it is empty or missing folders

bin CHANGES.txt contrib dist docs example licenses LICENSE.txt LUCENE_CHANGES.txt NOTICE.txt README.txt server

try

yum install ambari-infra-solr*