Support Questions
Find answers, ask questions, and share your expertise

HDP 2.6.3 Setup ambari cluster installaton - Need guide

I have installed Ambari-Server on ubuntu 14.04 and need to configute ambari cluster on my local machine need information on the below:

1. what is public/local repository. which i need to choose?

2. At Install Options: what i need to give in Target Hosts, and Host Registration information(SSH private key, SSH user account, ssh port number)

3. Is it posible to create multi node cluster with hadoop installation on a single machine if yes, how can i configure cluster for the same.

Kindly help me on the same with steps. Thanks in Advance.

1 ACCEPTED SOLUTION

@Chaitanya D,

1) If you choose public repository , then all the rpms will be downloaded from the hortonworks public repository. If you choose local repository then you need to set up a local yum repo and put the tarball there and run a webserver to serve these tarball. This is generally used in a setup where network access is blocked to outside world. You can use public repo.

2) In the target hosts , you need to mention hostnames of all the nodes which are going to be as part of the cluster.

SSH private key is ssh key of the user running ambari-server.

3) No. Each machine is treated as a single node.

You need to setup password-less ssh before giving the details in #2 . Since you are using a single node you do the below

#sudo su ---> to become root user
#ssh-keygen -----> generate the ssh keys
# cat ~/.ssh/id_rsa.pub >> ~/.ssh/authorized_keys  ---> for password-less ssh
#cat ~/.ssh/id_rsa ----> copy the output and put it in SSH private key in UI
# cat /etc/hostname ----> copy and put in target hosts

Thanks,

Aditya

View solution in original post

7 REPLIES 7

@Chaitanya D,

1) If you choose public repository , then all the rpms will be downloaded from the hortonworks public repository. If you choose local repository then you need to set up a local yum repo and put the tarball there and run a webserver to serve these tarball. This is generally used in a setup where network access is blocked to outside world. You can use public repo.

2) In the target hosts , you need to mention hostnames of all the nodes which are going to be as part of the cluster.

SSH private key is ssh key of the user running ambari-server.

3) No. Each machine is treated as a single node.

You need to setup password-less ssh before giving the details in #2 . Since you are using a single node you do the below

#sudo su ---> to become root user
#ssh-keygen -----> generate the ssh keys
# cat ~/.ssh/id_rsa.pub >> ~/.ssh/authorized_keys  ---> for password-less ssh
#cat ~/.ssh/id_rsa ----> copy the output and put it in SSH private key in UI
# cat /etc/hostname ----> copy and put in target hosts

Thanks,

Aditya

Thanks Aditya, I have chosen public repository with ubuntu 14.

In Install options:

given host as "localhost" and then added ssh private key (ssh/id_rsa file) and then ssh username: root, ssh port: 22.

But the cluster setup fails with message:

==========================
Creating target directory...
==========================

Command start time 2017-12-01 23:32:41

Permission denied (publickey,password).
SSH command execution finished
host=localhost, exitcode=255
Command end time 2017-12-01 23:32:41

ERROR: Bootstrap of host localhost fails because previous action finished with non-zero exit code (255)
ERROR MESSAGE: Permission denied (publickey,password).

STDOUT: 
Permission denied (publickey,password).

any suggestions please.

@Chaitanya D,

Oops!! There was a typo in my command above.It should be id_rsa.pub and not id_rsa Please run this command.

cat ~/.ssh/id_rsa.pub >> ~/.ssh/authorized_keys 
### to verify passwordless ssh run below command
ssh root@localhost --> should login without asking for passwordl

Make these changes and run the Register step again in Ambari GUI.

Thanks,

Aditya

I can login to ssh root@chaithu without password after performing the above said steps.

So given Host: localhost and chaithu (also tried giving localhost alone)

At ssh private key: choosen browse and given id_rsa

at ssh user name: chaithu (also tried with root)

ssh port number: 22

Is these details correct. As i am facing below failed error:

==========================
Creating target directory...
==========================

Command start time 2017-12-02 00:02:06

@Chaitanya D,

For the hostname : You can give either localhost or chaitu

For SSH private key : you should give SSH private of root

sudo su
cat ~/.ssh/id_rsa --> This is the private key for root

ssh username : root (not chaitu)

Can you please paste the complete log. There is no error on the log above.

Thankyou Aditya. You made my day 🙂 I made few changes and the cluster set up got completed.

Thanks a lot Aditya. Really you are awesome.

@Chaitanya D,

Thanks a lot for your kind words. Glad that it helped you. Can you please accept the answer. This will really help other community users.

; ;