Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

HDP 2.6.4 sandbox not starting on VirtualBox 5.2.6

Solved Go to solution
Highlighted

HDP 2.6.4 sandbox not starting on VirtualBox 5.2.6

New Contributor

I've been trying to get this set up for a while to no avail. The boot process seems to go fine, with no errors except for one after "waiting for server start" which exits with error code 1: reason "server is still not listening on port 8080 after 50 seconds". Though another post said that this isn't necessarily an issue. After that it continues to "Waiting for ambari services to start" and never progresses past that (see attached screenshot)

64386-boot-01.jpg


I have tried connecting to localhost:8888, 4200, and 8080. All of those refuse to connect.

From other questions, and responses, I've made sure that I have more than 8 GB allocated to the VM, I've verified the checksum, and I've re-imported the .ova a few times. I am running on Windows7.

Any help appreciated.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: HDP 2.6.4 sandbox not starting on VirtualBox 5.2.6

New Contributor

Hello, all. I solved the problem from my end. I had a VPN that was conflicting with the networking that VB tries to set up. Please be sure to turn off your VPN!

View solution in original post

19 REPLIES 19
Highlighted

Re: HDP 2.6.4 sandbox not starting on VirtualBox 5.2.6

Expert Contributor

@Ian Shrum Sorry to hear the HDP 2.6.4 sandbox does not start for you.

I'm hoping @glupu can provide suggestions on how to diagnose your issue.

I was successful deploying HDP 2.6.4 using VirtualBox 5.2.6 for Windows 10. It took about 5 minutes for Ports 8888, 4200 and 8080 to open and connect.

Re: HDP 2.6.4 sandbox not starting on VirtualBox 5.2.6

Rising Star

@Ian Shrum

Try connecting via SSH to the host machine ( ssh root@localhost -p2122 root/hadoop ) and then running docker ps to check if the docker container has been started. If so, from there login to the docker container ( ssh root@localhost -p2222 root/hadoop ) and run a ps ax command to check what processes are started.

It's very strange that not even shellinabox is started ( port 4200 ), we haven't seen this behavior before.

Highlighted

Re: HDP 2.6.4 sandbox not starting on VirtualBox 5.2.6

New Contributor

@glupu

I downloaded VMware and the appropriate HDP 2.6.4 image. Now I can ssh in through git bash. shellinabox and ambari are still refusing to connect though..

ps ax yielded the following:psax.jpg

Highlighted

Re: HDP 2.6.4 sandbox not starting on VirtualBox 5.2.6

New Contributor

@glupu

I too am facing the same issue

Highlighted
Highlighted

Re: HDP 2.6.4 sandbox not starting on VirtualBox 5.2.6

New Contributor

Thank you for the links, but I have already reviewed that material extensively and it did not help me. Which is why I am here.

Highlighted

Re: HDP 2.6.4 sandbox not starting on VirtualBox 5.2.6

New Contributor

I have similar problem, but difference is that I am running on sandbox on docker and final get through the start up. The process 'Waiting for ambari services to start...' took me about 25 minutes. Is it normal? I have set up enough memory (12GB) on my docker, so I don't think it is memory issue.

Highlighted

Re: HDP 2.6.4 sandbox not starting on VirtualBox 5.2.6

New Contributor

Hello everyone. I am happy to see this article which is exactly the problem I am having trying to bring new sandbox 2.6.4 up. Things were alright with 2.6.1.
Looking forward for the new update of this post.
Thanks.

Highlighted

Re: HDP 2.6.4 sandbox not starting on VirtualBox 5.2.6

New Contributor

Hi again.
I was just able to connect to new sandbox via same process I had done previously but with no success.

https://community.hortonworks.com/articles/98459/how-to-configure-networks-on-the-virtualbox-hdp-26....

Thanks.

Don't have an account?
Coming from Hortonworks? Activate your account here