Support Questions
Find answers, ask questions, and share your expertise

HDP 3 upgrade and Ranger/Hive postgres upgrade sequencing

HDP 3 upgrade and Ranger/Hive postgres upgrade sequencing

Explorer

I'm upgrading our cluster from HDP 2.6.3 to 3.1.0. We currently use two separate postgres instances for Ranger and Hive. HDP 3.1.0 no longer supports postgres 9.2, so it needs to be upgraded. My question is when (precisely) should I do this?

I've actually already upgraded both to postgres 10.6 (at the same time as I had to for ambari which is a third postgres instance), and upgraded Ambari to 2.7.3.0. However, the Hive metastore is failing to start with an odd postgres error - I think because postgres 10.6 isn't supported by HDP 2.6.3.

Shall I revert my postgres upgrade until I have upgraded HDP to 3.1.0? If so, precisely when should I upgrade postgres?

Thanks in advance