Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

HDP-UTILS-1.1.0.20 centos7 RPM dependency problems

HDP-UTILS-1.1.0.20 centos7 RPM dependency problems

New Contributor

Inside of HDP-UTILS-1.1.0.20-centos7.tar.gz there are a bunch RPMs that wont install on CentOS7.

Error: Package: lzo-devel-2.06-1.el6.x86_64 (/lzo-devel-2.06-1.el6.x86_64) Requires: lzo = 2.06-1.el6 Installed: lzo-2.06-8.el7.x86_64 (@anaconda) lzo = 2.06-8.el7 Error: Package: python-rrdtool-1.4.5-1.el6.x86_64 (/python-rrdtool-1.4.5-1.el6.x86_64) Requires: libpython2.6.so.1.0()(64bit) Error: Package: nagios-plugins-1.4.9-1.x86_64 (/nagios-plugins-1.4.9-1.x86_64) Requires: libmysqlclient.so.16(libmysqlclient_16)(64bit) Error: Package: libganglia-3.5.0-99.x86_64 (/libganglia-3.5.0-99.x86_64) Requires: libpcre.so.0()(64bit) Error: Package: snappy-devel-1.0.5-1.el6.x86_64 (/snappy-devel-1.0.5-1.el6.x86_64) Requires: snappy(x86-64) = 1.0.5-1.el6 Installed: snappy-1.1.0-3.el7.x86_64 (@anaconda) snappy(x86-64) = 1.1.0-3.el7 Error: Package: ruby-rrdtool-1.4.5-1.el6.x86_64 (/ruby-rrdtool-1.4.5-1.el6.x86_64) Requires: libruby.so.1.8()(64bit) Error: Package: ruby-rrdtool-1.4.5-1.el6.x86_64 (/ruby-rrdtool-1.4.5-1.el6.x86_64) Requires: ruby-devel Error: Package: perl-Crypt-DES-2.05-9.el6.x86_64 (/perl-Crypt-DES-2.05-9.el6.x86_64) Requires: perl(:MODULE_COMPAT_5.10.1) Error: Package: python-rrdtool-1.4.5-1.el6.x86_64 (/python-rrdtool-1.4.5-1.el6.x86_64) Requires: python(abi) = 2.6 Installed: python-2.7.5-34.el7.x86_64 (@anaconda) python(abi) = 2.7 python(abi) = 2.7 Error: Package: lua-rrdtool-1.4.5-1.el6.x86_64 (/lua-rrdtool-1.4.5-1.el6.x86_64) Requires: lua-devel Error: Package: ganglia-gmond-modules-python-3.5.0-99.x86_64 (/ganglia-gmond-modules-python-3.5.0-99.x86_64) Requires: libpcre.so.0()(64bit) Error: Package: ganglia-gmond-modules-python-3.5.0-99.x86_64 (/ganglia-gmond-modules-python-3.5.0-99.x86_64) Requires: libpython2.6.so.1.0()(64bit) Error: Package: nagios-plugins-1.4.9-1.x86_64 (/nagios-plugins-1.4.9-1.x86_64) Requires: libmysqlclient.so.16()(64bit) Error: Package: perl-Net-SNMP-5.2.0-4.el6.noarch (/perl-Net-SNMP-5.2.0-4.el6.noarch) Requires: perl(:MODULE_COMPAT_5.10.1) Error: Package: ganglia-gmond-3.5.0-99.x86_64 (/ganglia-gmond-3.5.0-99.x86_64) Requires: libpcre.so.0()(64bit) Error: Package: ganglia-gmetad-3.5.0-99.x86_64 (/ganglia-gmetad-3.5.0-99.x86_64) Requires: libpcre.so.0()(64bit) You could try using --skip-broken to work around the

2 REPLIES 2
Highlighted

Re: HDP-UTILS-1.1.0.20 centos7 RPM dependency problems

Mentor

@Dax Kelson nagios and ganglia are deprecated, we ship our own lzo, don't use the one shipped with OS.

Highlighted

Re: HDP-UTILS-1.1.0.20 centos7 RPM dependency problems

Mentor

@Dax Kelson are you still having issues with this? Can you accept the best answer or post your solution?

Don't have an account?
Coming from Hortonworks? Activate your account here