Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

HDP Upgrade - Pre-Upgrade checks failed from 2.6.3 to 3.1.0

Highlighted

HDP Upgrade - Pre-Upgrade checks failed from 2.6.3 to 3.1.0

New Contributor

Hi,

We are in the process of upgrading the HDP stack from 2.6.3 to 3.1.0 and we face the following error.

 Verify Ambari and Ranger Password Synchronization Reason: Credentials for user 'amb_ranger_admin' in Ambari do not match Ranger.Failed on: RANGER

We did change the password in Ranger and followed by the Ambari as well. Not sure why this synchronization is not happening?

Can any one help me out on this.

Thanks!

2 REPLIES 2

Re: HDP Upgrade - Pre-Upgrade checks failed from 2.6.3 to 3.1.0

Rising Star
@Sambasivam Subramanian

Check is "amb_ranger_admin" user is internal or external user, if it is external user then delete that user and create it as internal user and set the password for same, and update Ranger configs in Ambari UI with new password for "Ranger Admin user's password for Ambari

Re: HDP Upgrade - Pre-Upgrade checks failed from 2.6.3 to 3.1.0

New Contributor

I just changed the amb_ranger_admin password along with the admin password in the Ranger UI and in the ambari for ranger admin then it started working. Thanks!