Support Questions
Find answers, ask questions, and share your expertise

HDP Upgrade from 2.5.0 to 2.5.3 failed on Finalize Upgrade Pre-Check / Check Component Versions

HDP Upgrade from 2.5.0 to 2.5.3 failed on Finalize Upgrade Pre-Check / Check Component Versions

New Contributor

I'm in the finalize upgrade pre-check step of an Express upgrade from 2.5.0 to 2.5.3

There are errors in the Check Component Versions on several hosts in the cluster :

The following components were found to have version mismatches.  Finalize will not complete successfully:
uv0mt202.mydomain.tld: SOLR/SOLR_SERVER reports UNKNOWN
uv0mt204.mydomain.tld: SPARK2/SPARK2_THRIFTSERVER reports 2.5.0.0-1245
uv0mt201.mydomain.tld: SPARK2/SPARK2_CLIENT reports 2.5.0.0-1245
uv0hd001.mydomain.tld: SPARK2/SPARK2_CLIENT reports 2.5.0.0-1245
uv0mt202.mydomain.tld: SPARK2/SPARK2_CLIENT reports 2.5.0.0-1245
uv0hd002.mydomain.tld: SPARK2/SPARK2_CLIENT reports 2.5.0.0-1245
uv0bt003.mydomain.tld: SPARK2/SPARK2_CLIENT reports 2.5.0.0-1245
uv0bt002.mydomain.tld: SPARK2/SPARK2_CLIENT reports 2.5.0.0-1245
uv0bt001.mydomain.tld: SPARK2/SPARK2_CLIENT reports 2.5.0.0-1245
uv0mt204.mydomain.tld: SPARK2/SPARK2_CLIENT reports 2.5.0.0-1245
uv0mt204.mydomain.tld: SPARK2/SPARK2_JOBHISTORYSERVER reports 2.5.0.0-1245
2 REPLIES 2

Re: HDP Upgrade from 2.5.0 to 2.5.3 failed on Finalize Upgrade Pre-Check / Check Component Versions

New Contributor

Hi François,

We just had the same issue and we were able to solve it in a few minutes. It seems quite similar to https://issues.apache.org/jira/browse/AMBARI-14570 Indeed, it appears that theses 2 components (spark2 client and job history server) need to be restarted. This task should be triggered automatically. However, the actual Ambari configuration (see /var/lib/ambari-server/resources/stacks/HDP/2.5/upgrades/nonrolling-upgrade-2.5.xml) lack of such actions. Hopefully, you can manually solve this issue :

  1. Pause upgrade process
  2. Restart theses component using Ambari UI
  3. Restart upgrade process

Hope it helps

Re: HDP Upgrade from 2.5.0 to 2.5.3 failed on Finalize Upgrade Pre-Check / Check Component Versions

hi did you solved the problem ?

Michael-Bronson