Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

HDP2.4 Ranger HDFS Audit / Solr

Solved Go to solution
Highlighted

HDP2.4 Ranger HDFS Audit / Solr

Expert Contributor

Hi,

I was trying to setup ranger-hdfs-audit plugin and I can see it's successfully audting to hdfs and DB.

However the Audit UI doesn't show any data with message 'No Access Audit found!'

In Ranger xa_portal.log I see this error

2016-08-09 06:22:40,790 [http-bio-6080-exec-3] FATAL org.apache.ranger.solr.SolrMgr (SolrMgr.java:121) - Solr ZKHosts and URL for Audit are empty. Please set property ranger.audit.solr.zookeepers or ranger.audit.solr.urls 2016-08-09 06:22:40,791 [http-bio-6080-exec-3] WARN org.apache.ranger.solr.SolrAccessAuditsService (SolrAccessAuditsService.java:127) - Solr client is null, so not running the query. 2016-08-09 06:22:40,792 [http-bio-6080-exec-3] INFO org.apache.ranger.common.RESTErrorUtil (RESTErrorUtil.java:64) - Request failed. SessionId=816, loginId=admin, logMessage=Error connecting to search engine

I have not selected Solr anywhere, Is it possible to not use Solr?

Thanks,

Avijeet

1 ACCEPTED SOLUTION

Accepted Solutions

Re: HDP2.4 Ranger HDFS Audit / Solr

@Avijeet Dash

Can you check the value of property is set to "db"-

Services-> Ranger>Configs-> Advance->"ranger.audit.source.type"

Else you can search for "solr" in filter search tab and check if you have set solr anywhere in config.

Let me know if that works.

View solution in original post

2 REPLIES 2
Highlighted

Re: HDP2.4 Ranger HDFS Audit / Solr

Hi @Avijeet Dash - audit to Solr is now enabled by default. You can go into Ranger Configs in Ambari and disable it using the slider button as in the screenshot below:

6483-screen-shot-2016-08-09-at-130112.png

Re: HDP2.4 Ranger HDFS Audit / Solr

@Avijeet Dash

Can you check the value of property is set to "db"-

Services-> Ranger>Configs-> Advance->"ranger.audit.source.type"

Else you can search for "solr" in filter search tab and check if you have set solr anywhere in config.

Let me know if that works.

View solution in original post

Don't have an account?
Coming from Hortonworks? Activate your account here