Support Questions
Find answers, ask questions, and share your expertise
Announcements
Check out our newest addition to the community, the Cloudera Innovation Accelerator group hub.

HDP3.0.1 Ambari unable to stop all services...

capture.pngThanks in advance for trying to help me.

I am running HDP 3.0.1 VM and get an error whenever try to stop all services using ambari.

Below is the error message:-

Error message: java.lang.IllegalArgumentException: Invalid transition for servicecomponenthost, clusterName=Sandbox, clusterId=2, serviceName=ZEPPELIN, componentName=ZEPPELIN_MASTER, hostname=sandbox-hdp.hortonworks.com, currentState=STARTING, newDesiredState=INSTALLED

I have attached the screen shot also for this issue.

Thanks...

1 ACCEPTED SOLUTION

OK, It seems that the issue with stop_all script in Ambari UI somehow catch up the Zeppelin too into its script. Now if i Start Zeppelin manually(which was not running earlier), i can use stop all services option. At least the error message is helpful.

View solution in original post

4 REPLIES 4

Hi @Mukesh Kumar,

this happens when there is some inconsistency in the ambari database for the reported service Current state.

Is your zeppelin Notebook service in started state and is there any alert related to zeppelin in your ambari server.

Usually, when I face such issues I will restart my ambari-agent in the probalamtic host to resolve this issue.

can you please try to restart Ambari-agent using the below command in host: sandbox-hdp.hortonworks.com

ambari-agent restart

Please login and accept the answer if its helpful

Thanks @Akhil S Naik for reply. I think its not database inconsistency issue. But i have tried with your suggestion. Its not working. Even i cant see individual service stop drop-down at far right corner. Its just showing busy.

OK, It seems that the issue with stop_all script in Ambari UI somehow catch up the Zeppelin too into its script. Now if i Start Zeppelin manually(which was not running earlier), i can use stop all services option. At least the error message is helpful.

Hey @Mukesh Kumar,

so i assume the service zeppelin was not running was the issue . i thought i asked you about it in last comment 🙂

Glad that it resolved.