Support Questions
Find answers, ask questions, and share your expertise

HDP3.0 : Hive metastore(MySQL) installation failed (through Ambari)

Contributor

I am installing HDP3.0.0 (through Ambari) and installation of Hive metastore(MySQL) failed while installing mariadb dependency

Trace

Loaded plugins: langpacks Resolving Dependencies

--> Running transaction check

---> Package mariadb-server.x86_64 1:5.5.60-1.el7_5 will be installed

-> Processing Dependency: mariadb-libs(x86-64) = 1:5.5.60-1.el7_5 for package: 1:mariadb-server-5.5.60-1.el7_5.x86_64

--> Processing Dependency: mariadb(x86-64) = 1:5.5.60-1.el7_5 for package: 1:mariadb-server-5.5.60-1.el7_5.x86_64

--> Processing Dependency: perl-DBD-MySQL for package: 1:mariadb-server-5.5.60-1.el7_5.x86_64

--> Running transaction check

---> Package mariadb.x86_64 1:5.5.60-1.el7_5 will be installed

---> Package mariadb-libs.x86_64 1:5.5.60-1.el7_5 will be installed

---> Package perl-DBD-MySQL.x86_64 0:4.023-6.0.1.el7 will be installed Removing mariadb-libs.x86_64 1:5.5.60-1.el7_5 - u due to obsoletes from installed mysql-community-libs-5.7.16-1.el7.x86_64

--> Restarting Dependency Resolution with new changes.

--> Running transaction check

---> Package mariadb-libs.x86_64 1:5.5.60-1.el7_5 will be installed

--> Processing Dependency: mariadb-libs(x86-64) = 1:5.5.60-1.el7_5 for package: 1:mariadb-server-5.5.60-1.el7_5.x86_64

--> Processing Dependency: mariadb-libs(x86-64) = 1:5.5.60-1.el7_5 for package: 1:mariadb-5.5.60-1.el7_5.x86_64

--> Finished Dependency Resolution ###Error: Package: 1:mariadb-server-5.5.60-1.el7_5.x86_64 (ol7_latest)

Requires: mariadb-libs(x86-64) = 1:5.5.60-1.el7_5

Available: 1:mariadb-libs-5.5.52-1.el7.x86_64 (ol7_latest)

mariadb-libs(x86-64) = 1:5.5.52-1.el7

Available: 1:mariadb-libs-5.5.56-2.el7.x86_64 (ol7_latest)

mariadb-libs(x86-64) = 1:5.5.56-2.el7

Available: 1:mariadb-libs-5.5.60-1.el7_5.i686 (ol7_latest)

~mariadb-libs(x86-32) = 1:5.5.60-1.el7_5

Error: Package: 1:mariadb-5.5.60-1.el7_5.x86_64 (ol7_latest)

Requires: mariadb-libs(x86-64) = 1:5.5.60-1.el7_5

Available: 1:mariadb-libs-5.5.52-1.el7.x86_64 (ol7_latest)

mariadb-libs(x86-64) = 1:5.5.52-1.el7

Available: 1:mariadb-libs-5.5.56-2.el7.x86_64 (ol7_latest)

mariadb-libs(x86-64) = 1:5.5.56-2.el7

Available: 1:mariadb-libs-5.5.60-1.el7_5.i686 (ol7_latest)

~mariadb-libs(x86-32) = 1:5.5.60-1.el7_5

You could try using --skip-broken to work around the problem

You could try running: rpm -Va --nofiles --nodigest

Can I try installing mariadb-server through rpm and resume installation ? /usr/bin/yum -y install mariadb-server

Do I need to perform some manual steps, Can some one pls help.

2 REPLIES 2

Super Mentor
@Shantanu Sharma


You have already installed a different version of "mariadb-libs" lib which is causing the package conflict here. (also see "i686" and "x86_64" packages)

mariadb-libs(x86-64) = 1:5.5.56-2.el7 
~mariadb-libs(x86-32) = 1:5.5.60-1.el7_5 


So you can uninstalled the conflicting package then install the MariaDb on your own manually on the host then refer to the following steps to perform the HIve Database setup:
https://docs.hortonworks.com/HDPDocuments/Ambari-2.7.0.0/administering-ambari/content/amb_using_hive...

Contributor

Thanks for your response @Jay Kumar SenSharma

I have validated and I don't have mariadb lib installed on host where I am trying to install MySQL db for Hive metastore.

Below command is not returning anything.

rpm -qa | grep -i maria

Is there any version out-of-sync issue, I suspect by looking below in stack traceback.

Removing mariadb-libs.x86_64 1:5.5.60-1.el7_5 - u due to obsoletes from installed mysql-community-libs-5.7.16-1.el7.x86_64

; ;