Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

HUE Docker Image with HTTPS

HUE Docker Image with HTTPS

New Contributor

Hi,

 

I followed the instructions and pull the HUE image. I then tried to configure https, and it does not work no matter what I do. When trying to access the HUE page with https, it simples says ERR_SSL_PROTOCOL_ERROR, and when attempting to access the HUE page with http it says redirect not allowed. The console log shows the following, which seems to me as if HUE is not able to read the certificate. Any suggestion?

 

172.30.145.173 - - [29/Nov/2017 09:53:25] "POST /desktop/log_analytics HTTP/1.1" 403 -
[29/Nov/2017 09:53:25 +0000] _internal INFO 172.30.145.173 - - [29/Nov/2017 09:53:25] "POST /desktop/log_analytics HTTP/1.1" 403 -
172.30.145.173 - - [29/Nov/2017 09:53:25] "GET /static/desktop/ext/fonts/roboto-mono-400-normal.woff2 HTTP/1.1" 304 -
[29/Nov/2017 09:53:25 +0000] _internal INFO 172.30.145.173 - - [29/Nov/2017 09:53:25] "GET /static/desktop/ext/fonts/roboto-mono-400-normal.woff2 HTTP/1.1" 304 -
172.30.145.173 - - [29/Nov/2017 09:53:40] code 400, message Bad request syntax ('\x16\x03\x01\x00\xe8\x01\x00\x00\xe4\x03\x03Z\x1e\xf4$\xf2\xb6\x917\xd7\x9f\x13\x8a\x87R\x1b\xdc]>\x88NqR\xedZ\xa9\x81\x8f\x10\x10G\xac@\x00\x00&\x00\xff\xc0,\xc0+\xc0$\xc0#\xc0')
[29/Nov/2017 09:53:40 +0000] _internal ERROR 172.30.145.173 - - [29/Nov/2017 09:53:40] code 400, message Bad request syntax ('\x16\x03\x01\x00\xe8\x01\x00\x00\xe4\x03\x03Z\x1e\xf4$\xf2\xb6\x917\xd7\x9f\x13\x8a\x87R\x1b\xdc]>\x88NqR\xedZ\xa9\x81\x8f\x10\x10G\xac@\x00\x00&\x00\xff\xc0,\xc0+\xc0$\xc0#\xc0')
172.30.145.173 - - [29/Nov/2017 09:53:40] "??Z?$?7ן??R]>?NqR?Z???G?@&??,?+?$?#?" 400 -