Support Questions
Find answers, ask questions, and share your expertise

Hadoop 2.8 dependency is used in apache ambari 2.4.1 in ambari-metrics.

Contributor

WHile compiling ambari-metrics found that it is using hadoop 2.8 jar. Isn't it wrong to use hadoop 2.8 library when actually we are supporting hadoop 2.7.3? Those class files are not present in hadoop 2.7.3 and it throws error of i change that dependency to 2.7.3!!

1 REPLY 1

Re: Hadoop 2.8 dependency is used in apache ambari 2.4.1 in ambari-metrics.

Expert Contributor

Hi Aman,

I see the following in ambari-metrics pom

<hadoop.version>2.7.1.2.3.4.0-3347</hadoop.version>

Where do you see the hadoop-2.8 dependency?