Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Hbase Regions are not getting balanced even though balancer_switch is set to true

Highlighted

Hbase Regions are not getting balanced even though balancer_switch is set to true

Contributor

Hi,

We are seeing a scenario where HBase regions are not distributed evenly across all HBase region servers, even though balancer_swicth is set to true. This was working fine without any issues until recently. No config changes are made on the HBase cluster or restarts for past 5-6 months.

I manually triggered balancer using balancer command from HBase shell, but still no change in region allocation. No errors or warn messages in Master logs.

Please let me know what could go wrong and cause this scenario with Hbase.

Thanks in advance for the help.

3 REPLIES 3

Re: Hbase Regions are not getting balanced even though balancer_switch is set to true

Super Guru

@Saikiran Parepally are the number of regions evenly distributed? Or are you referring to the size of data per Region Server which is not evenly distributed?

Re: Hbase Regions are not getting balanced even though balancer_switch is set to true

Contributor

Hi @sunile.manjee I am referring to the number of regions. Some of the region servers have 30-40 regions and some have 70-80 regions.

Re: Hbase Regions are not getting balanced even though balancer_switch is set to true

New Contributor

how to resolve size of data per Region Server which is not evenly distributed?

@Saikiran Parepally