Support Questions
Find answers, ask questions, and share your expertise
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Hbase fail to create table

Hbase fail to create table

New Contributor

Hello, I am beginner in Hadoop. I am facing a problem when I try to create a simple table in Hbase.



$ hbase shell
16/02/24 10:50:48 INFO Configuration.deprecation: hadoop.native.lib is deprecated. Instead, use io.native.lib.available
HBase Shell; enter 'help<RETURN>' for list of supported commands.
Type "exit<RETURN>" to leave the HBase Shell
Version 1.0.0-cdh5.4.4, rUnknown, Mon Jul 6 16:59:55 PDT 2015

hbase(main):001:0> create 't4', 'c1'


The stop here, dont't return any message.


I have googled about this problem and i cant find nothing.


The Hbase log stopped here:


Feb 24, 11:09:26.158 AM INFO org.apache.hadoop.hbase.master.handler.CreateTableHandler

Create table t4

Feb 24, 11:09:26.215 AM INFO org.apache.hadoop.hbase.regionserver.HRegion

creating HRegion t4 HTD == 't4', {NAME => 'c1', DATA_BLOCK_ENCODING => 'NONE', BLOOMFILTER => 'ROW', REPLICATION_SCOPE => '0', VERSIONS => '1', COMPRESSION => 'NONE', MIN_VERSIONS => '0', TTL => 'FOREVER', KEEP_DELETED_CELLS => 'FALSE', BLOCKSIZE => '65536', IN_MEMORY => 'false', BLOCKCACHE => 'true'} RootDir = hdfs:// Table name == t4

Feb 24, 11:09:26.260 AM INFO org.apache.hadoop.hbase.regionserver.HRegion

Closed t4,,1456322966124.6197d48c2aac1e39bb3581f75e8a556f.

Feb 24, 11:09:26.279 AM INFO org.apache.hadoop.hbase.MetaTableAccessor

Added 2

Feb 24, 11:09:26.291 AM INFO org.apache.hadoop.hbase.master.AssignmentManager

Bulk assigning 1 region(s) across 6 server(s), round-robin=true

Feb 24, 11:09:26.293 AM INFO org.apache.hadoop.hbase.master.AssignmentManager

Bulk assigning done

Feb 24, 11:09:26.294 AM WARN org.apache.hadoop.hbase.zookeeper.ZKTableStateManager

Moving table t4 state from ENABLING to ENABLED

Feb 24, 11:09:26.301 AM INFO org.apache.hadoop.hbase.master.handler.CreateTableHandler

Table, t4, creation successful


In Zookeeper log presents this info:

Feb 24, 11:09:26.128 AM INFO org.apache.zookeeper.server.PrepRequestProcessor

Got user-level KeeperException when processing sessionid:0x2530f325c1b00ae type:create cxid:0xf00 zxid:0xb700003d6e txntype:-1 reqpath:n/a Error Path:/hbase/table-lock/t4 Error:KeeperErrorCode = NoNode for /hbase/table-lock/t4


I appreciate some help []s


Re: Hbase fail to create table

Master Guru
If you visit your HMaster Web UI at this point, do you see it load? If you do, do you see any of your 6 servers host your t4 region?

Per the log we seem to be creating the table structures/etc. OK but the assignment message does not seem to say where it got assigned to (or if it did).

I'd inspect the RS log to be sure if the tables are being assigned, and otherwise work on the issues shown there - that'd be the last bit missing before your create command returns.

Re: Hbase fail to create table

New Contributor

Hello Harsh J, Thanks for your attention. On Hbase Web Ui it shows that the 't4' don't have online regions.


Namespace Table Name Online Regions Description

defaultt40't4', {NAME => 'c1'}


I have tried everything , but i did not find the solution for this problem .


Re: Hbase fail to create table

New Contributor

In a desperate attempt I tried to add gateways in the roles instances of my hbase. Apparently it mades the master to access the servers regions, and now I can to create tables normally.

This is strange, because I have another cluster where I did not have to create the gateways roles.

Could someone help me understand that?


Re: Hbase fail to create table

Master Guru
That does not sound related to me either. It would be helpful knowing what was the "access" issue prior to this action, from the HMaster or HRegionServer logs (if you search 6197d48c2aac1e39bb3581f75e8a556f among them).