Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Hearbeat lost

Hearbeat lost

Rising Star

All of a sudden all my cluster machines lost the hearbeat. What could be wro

INFO 2018-06-03 06:14:50,210 NetUtil.py:70 - Connecting to https://localhost:8440/connection_info

INFO 2018-06-03 06:14:50,351 security.py:55 - Server require two-way SSL authentication. Use it instead of one-way...

INFO 2018-06-03 06:14:50,352 security.py:182 - Server certicate exists, ok

INFO 2018-06-03 06:14:50,352 security.py:190 - Agent key exists, ok

INFO 2018-06-03 06:14:50,352 security.py:198 - Agent certificate exists, ok

INFO 2018-06-03 06:14:50,353 security.py:93 - SSL Connect being called.. connecting to the server

ERROR 2018-06-03 06:14:50,361 security.py:80 - Two-way SSL authentication failed. Ensure that server and agent certificates were signed by the same CA and restart the agent.

In order to receive a new agent certificate, remove existing certificate file from keys directory. As a workaround you can turn off two-way SSL authentication in server configuration(ambari.properties)

Exiting..
2 REPLIES 2
Highlighted

Re: Hearbeat lost

Super Mentor

@Prakash Punj

Looks like you ahve configured 2 Way SSL between amabri server and agent (by default it is one way)

ERROR 2018-06-03 06:14:50,361 security.py:80 - Two-way SSL authentication failed. Ensure that server and agent certificates were signed by the same CA and restart the agent. 

In order to receive a new agent certificate, remove existing certificate file from keys directory. As a workaround you can turn off two-way SSL authentication in server configuration(ambari.properties)

.

Looks liek the 2 Way SSL communicaztion is failing. So please check the agent logs "ambari-agent.log" to see if you notice any SSL error.

.

Highlighted

Re: Hearbeat lost

Super Mentor

@Prakash Punj

There is recently an issue reported regarding 2 Way SSL communication: https://issues.apache.org/jira/browse/AMBARI-23920

So please check the workaround mentioned in the JIRA if you are hitting the same issue.

Don't have an account?
Coming from Hortonworks? Activate your account here