Support Questions

Find answers, ask questions, and share your expertise

Heartbeat Lost after upgrading from Ambari 2.4.2 to Ambari 2.5

Explorer

I upgrade the ambari server and agents version from the 2.4.2 to the 2.5. After upgradring I access to the ambari dashboard:

http://hdp-master1.ikerlan.es:8080, and some services are on Heartbeat Lost status. The services of the ambari-server are on that status, but for example it works when I access to HDFS: hdp-master1.ikerlan.es:50070.

15311-ambari.png

1 ACCEPTED SOLUTION

@Asier Gomez

First check Is your ambari-agent running on your host or not by,

ambari-agent status

If it is running fine then check your versions of ambari-server and ambari-agent on the host. Also check the entry in properties file of ambari,

yum list installed | grep ambari

Configuration file:-

/etc/ambari-agent/conf/ambari-agent.ini

[server]

hostname=Ambari-server Hostname

View solution in original post

5 REPLIES 5

@Asier Gomez

First check Is your ambari-agent running on your host or not by,

ambari-agent status

If it is running fine then check your versions of ambari-server and ambari-agent on the host. Also check the entry in properties file of ambari,

yum list installed | grep ambari

Configuration file:-

/etc/ambari-agent/conf/ambari-agent.ini

[server]

hostname=Ambari-server Hostname

Explorer

@nshelke Really thanks

Updating all the services it works:

This is my yum list installed on server:

yum list installed | grep ambari

ambari-agent.x86_64                         2.5.0.3-7               @ambari-2.5.0.3
ambari-metrics-grafana.x86_64               2.5.0.3-7               @ambari-2.5.0.3
ambari-metrics-hadoop-sink.x86_64           2.5.0.3-7               @ambari-2.5.0.3
ambari-metrics-monitor.x86_64               2.5.0.3-7               @ambari-2.5.0.3
ambari-server.x86_64                        2.5.0.3-7               @ambari-2.5.0.3

This is my yum list installed on agents:

yum list installed | grep ambari

ambari-agent.x86_64                         2.5.0.3-7               @ambari-2.5.0.3
ambari-metrics-hadoop-sink.x86_64           2.5.0.3-7               @ambari-2.5.0.3
ambari-metrics-monitor.x86_64               2.5.0.3-7               @ambari-2.5.0.3

15312-ambari.png

@Asier Gomez

Looking at you snapshots, I found some inconsistencies like,

You have not upgrade ambari-agent package on ambari-server host and other packages also, see

yum list installed | grep ambari

	ambari-agent.x86_64  2.4.2.0-136  @Updates-ambari-2.4.2.0
	ambari-metrics-grafana.x86_64  2.4.2.0-136  @Updates-ambari-2.4.2.0
	ambari-metrics-hadoop-sink.x86_64  2.4.2.0-136  @Updates-ambari-2.4.2.0
	ambari-metrics-monitor.x86_64  2.4.2.0-136  @Updates-ambari-2.4.2.0

all have version 2.4.2.0-136, You have to upgrade all these component as well.

Also on ambari-agent host,

yum list installed | grep ambari
ambari-metrics-hadoop-sink.x86_64  2.4.2.0-136  @Updates-ambari-2.4.2.0
ambari-metrics-monitor.x86_64  2.4.2.0-136  @Updates-ambari-2.4.2.0

Here also you need to upgrade these two packages to 2.5.0.3-7.

Then restart the ambari-agent, This will solve your problem.

Explorer

Yes it was this, I just update all the services and it works 🙂 Really thanks @nshelke

@Asier Gomez

Thanks.