Support Questions
Find answers, ask questions, and share your expertise

Help with Can't start the sandbox/Ambari Server: REASON: Server not yet listening on http port 8080 after 50 seconds. Exiting.

Explorer

Hello,

I have an Hadoop environment and using Hortonworks Data Platform 2.6.1, https://hortonworks.com/products/data-platforms/hdp/

So, I have Ambari Server installed within a docker on my Linux VM. When I start the Ambari Server, I get

DB configs consistency check: no errors and warnings were found.
ERROR: Exiting with exit code 1.
REASON: Server not yet listening on http port 8080 after 50 seconds. Exiting.

I have read that I need to change the timeout setting in the ambari-properties file. Like:

Edit the "/etc/ambari-server/conf/ambari.properties" and increase the following property value to 120 or 150 seconds.

server.startup.web.timeout=120

However, it seems that I have to be inside the container to change the settings, but I can’t start the container. I don't see that folder, so I am thinking I need to be inside my container to change the file. How can I look for the ambari.properties from inside the container?

8 REPLIES 8

Super Mentor

Are you using HDP Snadbox? In that case the VM ssh port will be 2122, But if you want to Edit HDP/Ambari rel;ated configs then you will need to do SSH on port 2222 to login to the Docker container where the ambari & HDP services are running.

In order to edit the ambari.properties you will need to do SSH on sandbox port 2222 as following:

# ssh root@127.0.0.1  -p 2222
Enter Password: hadoop

.

The other option will be to use the Web Terminal

http://localhost:4200

Explorer

Yes, I am using the HDP sandbox. I logged in with ssh -p 2222 root@localhost.

So, I can see the ambari.properties file now.

However, I don't see the line in the file: server.startup.web.timeout=120

Would I add this to the file, if missing?

Super Mentor

You will need to add that line explicitly inside the "ambari.properties" something like:

server.startup.web.timeout=150

.

The delay in ambari server startup can be normal in Sandbox containers because ti runs a lots of services/components on a single host so it will be bit slow startup compared to dedicated ambari hosts. So in order to avoud seeing those Errors better tos e the value to little large for sandbox like 150 seconds.

Explorer

OK, I set it to 120. I did add the line to the file. I don't see the error now and ambari server says its started.

Super Mentor

Wonderful!!! Are you able to access the ambari UI now?

http://localhost:8080

Super Mentor
@Paul Byrum

If this resolved your original query/issue then please mark this HCC thread as answered by clicking on "Accept" link on the correct answer, That way it will help other HCC users to quickly find the answers.

Explorer

Now when I run my sudo ./start_sandbox-hdp.sh it hangs. It gets stuck on "Ambari Server 'start' completed successfully'

Server PID at: /var/run/ambari-server/ambari-server.pid

Server out at: /var/log/ambari-server/ambari-server.out

Server log at: /var/log/ambari-server/ambari-server.log

Waiting for server start.............................................................

Server started listening on 8080 DB configs consistency check: no errors and warnings were found.

Ambari Server 'start' completed successfully.


Explorer

Thanks, this starts my ambari server, but when I run sudo ./start_sandbox-hdp.sh it hangs on "Ambari Server 'start' completed successfully." I will create a new post for this issue.

; ;