Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Hi.. i am using HDP 2.1.5 i have test env and prod env..while i try to browse yarn->quicklinks->RM UI in PROD error display webpage not available ..but i can browse in Dev ..can i know the error

Hi.. i am using HDP 2.1.5 i have test env and prod env..while i try to browse yarn->quicklinks->RM UI in PROD error display webpage not available ..but i can browse in Dev ..can i know the error

Rising Star
 
8 REPLIES 8

Re: Hi.. i am using HDP 2.1.5 i have test env and prod env..while i try to browse yarn->quicklinks->RM UI in PROD error display webpage not available ..but i can browse in Dev ..can i know the error

Have you confirmed the RM port is open for incoming traffic from your client in your Prod environment?

Re: Hi.. i am using HDP 2.1.5 i have test env and prod env..while i try to browse yarn->quicklinks->RM UI in PROD error display webpage not available ..but i can browse in Dev ..can i know the error

Rising Star

@slachterman

I think it was not opened ..i got below error while i tenet into that port

telnet: connect to address xx.xx.xx.xx: Connection refused

Re: Hi.. i am using HDP 2.1.5 i have test env and prod env..while i try to browse yarn->quicklinks->RM UI in PROD error display webpage not available ..but i can browse in Dev ..can i know the error

@sankar rao sounds like it could be a network connectivity issue. You can confirm in Ambari, in YARN > Config > Advanced yarn-site that yarn.resourcemanager.webapp.address is set to the port that you're attempting to reach (via your browser and telnet).

If that configuration is as expected, you'll need to troubleshoot at the network level. Please let us know what you find.

Re: Hi.. i am using HDP 2.1.5 i have test env and prod env..while i try to browse yarn->quicklinks->RM UI in PROD error display webpage not available ..but i can browse in Dev ..can i know the error

Rising Star

@slachterman Thank you for your time...

actually i came to know that not only yarn , non of web UI is working(yarn,hbase,folcon,mapreduce..etc)

so what is issue for that ...please help me..

Re: Hi.. i am using HDP 2.1.5 i have test env and prod env..while i try to browse yarn->quicklinks->RM UI in PROD error display webpage not available ..but i can browse in Dev ..can i know the error

Is the cluster up? Can you reach the Ambari interface? What is the network architecture between your client and the cluster?

Re: Hi.. i am using HDP 2.1.5 i have test env and prod env..while i try to browse yarn->quicklinks->RM UI in PROD error display webpage not available ..but i can browse in Dev ..can i know the error

Rising Star

@slachterman

yes my cluster is up and running and i can open ambari...i am sorry to say ..i was completed unaware of network architecture..what is it mean network architecuture between client and cluster?

Re: Hi.. i am using HDP 2.1.5 i have test env and prod env..while i try to browse yarn->quicklinks->RM UI in PROD error display webpage not available ..but i can browse in Dev ..can i know the error

This sounds like a network connectivity issue to me, so I was asking whether there is a firewall between your client and the servers in the cluster or some other reason that ports (such as 8088 for the RM UI) would be blocked between your client and the servers in the cluster.

Re: Hi.. i am using HDP 2.1.5 i have test env and prod env..while i try to browse yarn->quicklinks->RM UI in PROD error display webpage not available ..but i can browse in Dev ..can i know the error

Rising Star

@slachterman

i i could see below output when i try #iptables -L -n in server. i thing there is firewall is off.

Chain INPUT (policy ACCEPT)

target prot opt source destination

Chain FORWARD (policy ACCEPT)

target prot opt source destination

Chain OUTPUT (policy ACCEPT)

target prot opt source destination