Support Questions
Find answers, ask questions, and share your expertise

Hi, my Ambari server was working this morning quite well but its been 5 hours that I got this error when I try to start it.I tried everything so any help is welcomed!Thank you

New Contributor
  • Using python /usr/bin/python
  • Starting ambari-server
  • WARNING:The hostname was not found in the reverse DNS lookup.This may result in incorrect behavior.Please check the DNS setup and fix the issue.
  • AmbariServer running with administrator privileges.
  • Organizing resource files at /var/lib/ambari-server/resources...
  • Ambari database consistency check started...
  • No errors were found.
  • Ambari database consistency check finished
  • Server PID at:/var/run/ambari-server/ambari-server.pid
  • Serverout at:/var/log/ambari-server/ambari-server.out
  • Server log at:/var/log/ambari-server/ambari-server.log
  • Waitingfor server start....................
  • ERROR:Exitingwithexit code -1.
  • REASON:AmbariServer java process died with exitcode 1.Check/var/log/ambari-server/ambari-server.outfor more information.
  • 1 ACCEPTED SOLUTION

    Accepted Solutions

    New Contributor

    @Divakar Annapureddy @Sonu Sahi

    Hi thank you so much for your help.Actually, the issue was due to the Ambari Database.I reminded that I accidently dropped the Ambari Database.So I re-installed the Database and now everything working well. Thank you 🙂

    View solution in original post

    3 REPLIES 3

    Guru

    hi @Mamy D

    have you checked the ambari-server.out file mentioned in the error message for additional detail that may reveal the root cause?

    @Mamy D

    it's hard to tell with provided information.

    plz provide more details like

    Ambari server version:

    HDP Stack version:

    Is mysql up and running?

    which sql connector are you using? run below command and provide output

    ls -lrt /usr/share/java/mysql-connector-java*

    copy last 20 lines error message from amabri-server log, run below command for that.

    tail -20 /var/log/ambari-server/ambari-server.log

    Thanks,

    Divakar

    New Contributor

    @Divakar Annapureddy @Sonu Sahi

    Hi thank you so much for your help.Actually, the issue was due to the Ambari Database.I reminded that I accidently dropped the Ambari Database.So I re-installed the Database and now everything working well. Thank you 🙂

    View solution in original post