Support Questions
Find answers, ask questions, and share your expertise

Hive 3.1.0 authentification / authorization

Hive 3.1.0 authentification / authorization

New Contributor

Hi,

we started to use HDP3.1.0, we also upgraded hive to 3.1.0. and we use JDBC connector for SQL developer (by Cloudera).

But there is an issue. If we enable authorization we get following error in SQL developer:

HiveSQLException:Error while compiling statement: FAILED: NullPointerException null:17:16

I think it is because JDBCconnector by cloudera supports hive up to version 2.6.2 only.

And if we enable PAM authentification (PAM), we always get error :

failure: Error validating the login

Everything worked fine when we were using HDP 2.6. . These issues came up after upgrade.

Is it possible that this is because of new Hive version ? Should we downgrade HIVE (can we downgrade it?)

Thanks

1 REPLY 1

Re: Hive 3.1.0 authentification / authorization

@Patrik Plecho You may want to ask this question over in The Cloudera community: http://community.cloudera.com
Bill Brooks, Community Moderator
Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.