Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

Hive Ambari View coniguration for Hive SSL

avatar

What configuration is required in the Hive Ambari View for supporting Hive SSL?

1 ACCEPTED SOLUTION

avatar
Rising Star
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
8 REPLIES 8

avatar

avatar
@Sri Bandaru- No. That's for Ambari HTTPS. I'm referring to SSL of HiveServer2 connections.

avatar

@Sean Roberts, Is there any specific reason you are looking for SSL and not using kerberos authentication instead?

I can see kerberos authentication documentation.(but not sure if there is any for SSL)

https://docs.hortonworks.com/HDPDocuments/Ambari-2.1.0.0/bk_ambari_views_guide/content/section_kerbe...

avatar

As far as I know Kerberos is for authentication. Not the encryption of Hive communication.

avatar

@Sean Roberts, you can use kerberos authentication instead and configure SASL for encrypting traffic

https://docs.hortonworks.com/HDPDocuments/Ambari-2.1.0.0/bk_ambari_views_guide/content/section_kerbe...

you can encrypt the traffic by enabling following property with your kerberos authentication.

<property>
<name>hive.server2.thrift.sasl.qop</name>
<value>auth-conf</value>
<description>Sasl QOP value; one of 'auth', 'auth-int' and 'auth-conf'</description>
</property>

Change the HIVE AUTHENTICATION field as per the above document to add sasl.qop=auth-conf at the end

auth=kerberos;principal=hive/_HOST@hortoworks.com;sasl.qop=auth-conf

avatar
New Contributor

I have the same question. I am trying to run Ambari Hive view when HiveServer2 is SSL enabled, but get the following error.

java.lang.NullPointerException at org.apache.ambari.view.hive2.internal.HiveConnectionWrapper.isLoginError(HiveConnectionWrapper.java:115) at org.apache.ambari.view.hive2.internal.HiveConnectionWrapper.connect(HiveConnectionWrapper.java:87) at org.apache.ambari.view.hive2.resources.browser.ConnectionService.attemptHiveConnection(ConnectionService.java:102) at org.apache.ambari.view.hive2.resources.browser.ConnectionService.attemptConnection(ConnectionService.java:85) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:498)

If I disable SSL, view executes without error.

For beeline, I provide additional parameters

beeline>!connect jdbc:hive2://hostname:10000/default;ssl=true;sslTrustStore=/var/log/ambari-server/hive-next-view/hive.jks;trustStorePassword=********

How do I provide the same info in the Hive view?

avatar
Rising Star
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login

avatar
New Contributor

Thanks for the help.

I was able to run the view after setting the Hive session param to ssl=true;sslTrustStore=/var/log/ambari-server/hive-next-view/hive.jks;trustStorePassword=********