Support Questions
Find answers, ask questions, and share your expertise

Hive CLI not able to start in HDP sanbox

Solved Go to solution
Highlighted

Hive CLI not able to start in HDP sanbox

Explorer

I got below error while start Hive CLI under root. FYI, Hive seems work fine under Ambari, in which i can run sql command.

Thanks.

[root@sandbox aniu]# hive cli WARNING: Use "yarn jar" to launch YARN applications. Logging initialized using configuration in file:/etc/hive/2.4.0.0-169/0/hive-log4j.properties Exception in thread "main" java.lang.RuntimeException: org.apache.tez.dag.api.TezException: org.apache.hadoop.yarn.exceptions.YarnException: Failed to submit application_1475289177250_0006 to YARN : Application application_1475289177250_0006 submitted by user root to unknown queue: default

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Hive CLI not able to start in HDP sanbox

please check RM queues setup correctly, seems there is no default queue configured

View solution in original post

3 REPLIES 3
Highlighted

Re: Hive CLI not able to start in HDP sanbox

please check RM queues setup correctly, seems there is no default queue configured

View solution in original post

Highlighted

Re: Hive CLI not able to start in HDP sanbox

Explorer

Thanks both and i am able to proceed to next step.

Highlighted

Re: Hive CLI not able to start in HDP sanbox

@Rajkumar Singh It looks like you are trying to submit the job to default queue which is unknown. Have you changed Yarn queues configuration?