Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Hive LLAP issue.

Hive LLAP issue.

Hi I am using HDP 2.6.2.14.

I have enabled the LLAP. First time LLAP restarted successfully. But when I tried to restart but not getting start.

javax.net.ssl.SSLException: Received fatal alert: unknown_ca

Error messages on a container launched by Slider AM

Also I have copied phoenix-4.7.0.2.6.2.14-5-client.jar to following path for phoenix connectivity.

/usr/hdp/2.6.2.14-5/hive2/auxlib/phoenix-4.7.0.2.6.2.14-5-client.jar

8 REPLIES 8

Re: Hive LLAP issue.

Expert Contributor


@Ashnee Sharma Try regenerate the keytab for LLAP.

Re: Hive LLAP issue.

@Matt Andruff

My cluster is non secure.

Re: Hive LLAP issue.

Cloudera Employee

Re: Hive LLAP issue.

@nkumar

I have tried this. But didn't worked.

Re: Hive LLAP issue.

Expert Contributor

@Ashnee Sharma I think @nkumar means well but is lazy. He didn't point out that the troubleshooting section in the article he lazyily pointed you to actually specifically mentions your issue. I encountered it too and the solution was to force python to allow unsecure certs at a server level. for way too much background check this out: https://lwn.net/Articles/611243/

Here's a fix that works at the server level:

Read this before making the change: https://access.redhat.com/articles/2039753

Edit this file on all nodes and set verify to "disable"... .this is a way to fix things.... not necessarily the best way.. so please read the articles before you choose if this path is for you.

/etc/python/cert-verification.cfg

[https]
verify=disable

Re: Hive LLAP issue.

@Matt Andruff

Thanks I will check it and reply.

Re: Hive LLAP issue.

@Matt Andruff

After disabling

[https]

verify=disable issue is resolved.

Re: Hive LLAP issue.

Expert Contributor

@Ashnee Sharma I think @nkumar means well but is lazy. He didn't point out that the troubleshooting section in the article he lazyily pointed you to actually specifically mentions your issue. I encountered it too and the solution was to force python to allow unsecure certs at a server level. for way too much background check this out: https://lwn.net/Articles/611243/

Here's a fix that works at the server level:

Read this before making the change: https://access.redhat.com/articles/2039753

Edit this file on all nodes and set verify to "disable"... .this is a way to fix things.... not necessarily the best way.. so please read the articles before you choose if this path is for you.

/etc/python/cert-verification.cfg

[https]
verify=disable