Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Hive Metastore won't start after enabling Kerberos

Highlighted

Re: Hive Metastore won't start after enabling Kerberos

Explorer

No solution yet - please upvote my question, maybe others will give it a crack.

Highlighted

Re: Hive Metastore won't start after enabling Kerberos

Master Collaborator

Can you check the values of these three properties?

hive.cluster.delegation.token.store.zookeeper.connectString
hive.zookeeper.quorum
hive.cluster.delegation.token.store.class

I suspect that some of these may not be set correctly particularly the first two which are cluster specific. The last one should be set to "org.apache.hadoop.hive.thrift.ZooKeeperTokenStore".

Highlighted

Re: Hive Metastore won't start after enabling Kerberos

Explorer

Thanks for trying Deepesh, but I think these are right:

hive.cluster.delegation.token.store.zookeeper.connectString

hwmaster1.home:2181,hwmaster4.home:2181,hwmaster3.home:2181

hive.zookeeper.quorum

hwmaster1.home:2181,hwmaster4.home:2181,hwmaster3.home:2181

hive.cluster.delegation.token.store.class

org.apache.hadoop.hive.thrift.ZooKeeperTokenStore

Highlighted

Re: Hive Metastore won't start after enabling Kerberos

Master Collaborator

Actually didn't realize that its an HA install. As per the documentation, for HA enabled cluster

hive.cluster.delegation.token.store.class=org.apache.hadoop.hive.thrift.DBTokenStore

Can you give that a try and let us know if that solves it? You will need to bounce your Hive services.

Highlighted

Re: Hive Metastore won't start after enabling Kerberos

Expert Contributor
@Oliver Meyn

Did you ever find a solution to this? Running into the same issue after disabling and then re-enabling kerberos.

Highlighted

Re: Hive Metastore won't start after enabling Kerberos

Explorer

Sorry, wish I had but in the end I gave up and rebuilt as 2.3 (this was a test cluster and the client never had this problem in the prod cluster I was trying to recreate).

Re: Hive Metastore won't start after enabling Kerberos

Expert Contributor

@Oliver Meyn

Thanks...guess i'll just have to disable kerberos till then. What was your path to this error? Did you ever disable kerberos at some point and then try to re-enable it? (this is what I did) Im using HDP 2.5

Highlighted

Re: Hive Metastore won't start after enabling Kerberos

Explorer

Wow, I'm surprised you're seeing this in 2.5, I had strong hope that it was an artifact of old software. My path to it was just a simple 2.2 cluster setup and once everything was working I enabled Kerberos.

Highlighted

Re: Hive Metastore won't start after enabling Kerberos

Guru

If the cluster is non-kerberized, it seems like it happens when the cluster is kerberized and then rolled back. If kerberos is not enabled and value for the following property is set to true, it should be disabled and restart should be attempted.

hive.metastore.sasl.enabled
Highlighted

Re: Hive Metastore won't start after enabling Kerberos

New Contributor

it is worked

Don't have an account?
Coming from Hortonworks? Activate your account here