Support Questions
Find answers, ask questions, and share your expertise
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Hive-PostgresDB issue


Hive-PostgresDB issue


I am trying to install hive in my cluster which has Kerberos, KTS/KMS enabled 5.14 cluster(managed by Cloudera manager), Sqoop client(I didn't do any change related to PostgresDB- straight installed through CM UI)

Situation is like this -

I have a Postgres DB setup externally on a linux machine which is not part of the cluster. Most likely all the Cloudera services use this Postgres DB (I could see a cloudera DB in my Postgres linux host)

I created a  hive metastore(hivestore) and also a hive user on the external Postgres host- granted all permission for user hive

psql -h <postgres host> -U hive -d hivestore

Password for user hive:
psql (9.2.24)
Type "help" for help.



Untill here it worked fine. According to cloudera docs I am fine untill here but now I go to my Cloudera manager and tried to add service hive which asks me to assign roles in second step and next step it  asks me to select a host which has a database server running and the username and password to test database connectivity

Now, this gives me error saying:


 No database server found running on host <my clusterhost>


I know the reason because my Postgres DB server and my hive metastore is on a external linux host and is not part of my cluster. How do I deal with this situation?


Any help is appreciated and also let me know what you think went wrong. Is there anything need to installed on my cluster hosts?