Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Hive problems of connection to port 10000

Highlighted

Hive problems of connection to port 10000

New Contributor

Hello,

I have recently installed cloudera manager and cdh 5. It results that when I enterd Hue and open editor Hive it appears the next problem that unsables me to do the queries.

   Could not connect to cm:10000

   Could not connect to cm:10000 (code THRIFTTRANSPORT): TTransportException('Could not connect to     cm:10000',)

 

I read lots of posts of people with the same problem but I do not find the solution. I would say that the database is not connected with hive but I am not sure. I also read some instructions of this website but without success.

 

If I process this command, the shell turns out the next error:

     -bash: HIVE_HOME/bin/hive: No existe el fichero o el directorio
[2]   Salida 1                nohup hiveserver2

If I process this command, the shell turns out the next error:

Redirecting to /bin/systemctl status hive-server2.service
Unit hive-server2.service could not be found.

 

I also leave the safemode of the name node...

 

I also tried to do the configuration of this link: https://www.cloudera.com/documentation/enterprise/5-8-x/topics/cdh_ig_hive_metastore_configure.html

but still have the same problem

 

Could you help me please?

 

I am a bit desperated

 

Thanks a lot