Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Hive server fails to connect

Hive server fails to connect

Expert Contributor

We recently started using Tableau and allowed Tableau online to access our hive server.

Now, from that point, for about 2 hours in morning 10 to 12, our hive queries fail with

 

Connecting to jdbc:hive2://ip-xxx-xx-x-xxx.ap-south-1.compute.internal:10000/default
Unknown HS2 problem when communicating with Thrift server.
Error: Could not open client transport with JDBC Uri: jdbc:hive2://ip-xxx-xx-x-xxx.ap-south-1.compute.internal:10000/default: java.net.SocketException: Connection reset (state=08S01,code=0)
No current connection
Intercepting System.exit(2)
Failing Oozie Launcher, Main class [org.apache.oozie.action.hadoop.Hive2Main], exit code [2]




If I try to connect manually, I can connect fine:

beeline -u jdbc:hive2://xxx-xx-x-xxx:10000/

I then have to take off tableau whitelisted IP and after about 10 minutes, it comes back up. We do not have a lot of queries on Tableau. What could be the issue? I have taken off limit to accept connections from zookeeper just in case it had anything to do with it. Pointers?

 

1 REPLY 1
Highlighted

Re: Hive server fails to connect

Guru
Any clues from HS2 server log? Please check at the exact time if there is any error reported on HS2 side. If nothing, then it is likely client did not reach to HS2 at all, so problem either at network level or on the client side.