Support Questions
Find answers, ask questions, and share your expertise

Hive view issue

PFA for whole issue we are facing . hive-view-error-log.txt

using Ambari 2.4.1 and HDP2.5 .

FYI - Ambari server has started with root user.

we have configured below properties in Ambari.



Getting below error in Hive view .

Error :

Caused by: Unauthorized connection for super-user: root from IP xx.xx.xx.xx at sun.reflect.GeneratedConstructorAccessor3693.newInstance(Unknown Source) at sun.reflect.DelegatingConstructorAccessorImpl.newInstance( at java.lang.reflect.Constructor.newInstance( at org.apache.hadoop.ipc.RemoteException.instantiateException( at org.apache.hadoop.ipc.RemoteException.unwrapRemoteException( at org.apache.hadoop.hdfs.web.WebHdfsFileSystem.toIOException( at org.apache.hadoop.hdfs.web.WebHdfsFileSystem.validateResponse( at org.apache.hadoop.hdfs.web.WebHdfsFileSystem.access$200( at org.apache.hadoop.hdfs.web.WebHdfsFileSystem$FsPathOutputStreamRunner$1.close( at org.apache.ambari.view.utils.hdfs.HdfsUtil.putStringToFile( ... 101 more

Caused by: org.apache.hadoop.ipc.RemoteException( Unauthorized connection for super-user: root from IP xx.xx.xx.xx at org.apache.hadoop.hdfs.web.JsonUtil.toRemoteException( at org.apache.hadoop.hdfs.web.WebHdfsFileSystem.validateResponse( ... 104 more


Super Mentor


Try to set up a proxy user forrootin core-site.xml by clicking

HDFS > Configs > Custom core-site > Add Property. In the Add Property dialog box, you add the following keys and values:



Or please make sure that the hostname contains the ambari FQDN (instead of IP Address)


We have added above 2 properties as you mentioned. still we are facing the same issue

Super Mentor


Instead of IP Address can you define the ambari hostname there. Looks like you have defined the IP Address.



I have mentioned FQDN only in Ambari .mentioned wrongle here , sorry for that .

Super Mentor


Are you able to open the following kind of URL from ambari server host or other hosts ?



Super Mentor

Also please check if the hive is also set as proxyuser properly as :



Ideally if you are running your ambari as "root" user then in order to fix the IP Address based unauthorized issue you should just deal with the "hadoop.proxyuser.root.hosts".

So can you check if setting this value to * is working? Do you have multiple IP Address associated with ambari server?



Or if you are setting the ambari's correct FQDN there? I mean the output of following , followed by a "Restart Required Of Dependent" services.

hostname -f

@Jay SenSharma

I am able to acess above link .

Result of the above URL :



I have mentioned right value to right FQDN value to hadoop.proxyuser.root.hosts .
Still Having the issue
; ;