Support Questions
Find answers, ask questions, and share your expertise

Hive will not start - stuck hanging

New Contributor

Relatively new to Hive/Hadoop. For the past two days,

I haven't been able to launch Hive and it's been stuck hanging after I try to start it from PuTTy. It hangs on

WARNING: Use "yarn jar" to launch YARN applications.

Logging initialized using configuration in file:/etc/hive/2.4.0.0-169/0/hive-log4j.properties

I've tried killing all Yarn Application tasks but that doesn't work. I've tried restarting my Ambari environment. I've tried debugging at Hive Launch but it just goes on forever. Launching in MapReduce (as opposed to Tez) gets it launched, but it isn't able to perform any operators after that (e.g. create table/ select count(*)). This is what it looks like when I debug at Hive launch (it never ends!):

8372-asduhoiasdhou.png

I'd appreciate if someone could help me out or point me in some direction! Thanks

8371-111111x2x21.png

1 ACCEPTED SOLUTION

@Fabien

in ambari click on hosts (upper pane of the UI) then click on the hostname, it will list you all the services along with the status.. you will find nodemanger here. click on the dropdown by selecting start.. it will start the nodemanager

View solution in original post

7 REPLIES 7

@Fabienwith the ambari dashboard view it looks it's a single node cluster and your nodemanger is down, can you restart it and run the query again.

New Contributor

Hi Rajkumar, do you mind telling how I can restart the node/nodemanager?

@Fabien

in ambari click on hosts (upper pane of the UI) then click on the hostname, it will list you all the services along with the status.. you will find nodemanger here. click on the dropdown by selecting start.. it will start the nodemanager

New Contributor

@Rajkumar Singh, thanks for the guidance. I can't find the "dropdown by selecting start". I see Nodemanager, but can't find the start option. See below.

Thanks

8375-nodemanager.png

@Fabien

could you please try login with the admin user instead of maria_dev.

New Contributor

@Rajkumar Singh user/pass: admin/admin doesn't work. I've been using maria_dev the entire time. Is there another way around this?

@Fabien

could you please try these steps to login ambari using admin

open a terminal do

ssh root@127.0.0.1 -p 2222

ambari-admin-password-reset // update admin passwd ambari-agent restart

now open ambari ui and login using admin/<passwd you setted>

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.