Support Questions
Find answers, ask questions, and share your expertise

HiveServer 2 process not starting

Contributor

I have installed amabari and trying to set up hive. I was not able to start hiveserver2 process, hive metastore and webhcat are up and running. It is stopped and i am getting the below error. Can someone help me. Thanks

Connection failed on host hadoop-node1localdomain.training:10000 (Traceback (most recent call last): File "/var/lib/ambari-agent/cache/common-services/HIVE/0.12.0.2.0/package/alerts/alert_hive_thrift_port.py", line 200, in execute check_command_timeout=int(check_command_timeout)) File "/usr/lib/python2.6/site-packages/resource_management/libraries/functions/hive_check.py", line 74, in check_thrift_port_sasl timeout=check_command_timeout) File "/usr/lib/python2.6/site-packages/resource_management/core/base.py", line 154, in __init__ self.env.run() File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 160, in run self.run_action(resource, action) File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 124, in run_action provider_action() File "/usr/lib/python2.6/site-packages/resource_management/core/providers/system.py", line 238, in action_run tries=self.resource.tries, try_sleep=self.resource.try_sleep) File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 70, in inner result = function(command, **kwargs) File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 92, in checked_call tries=tries, try_sleep=try_sleep) File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 140, in _call_wrapper result = _call(command, **kwargs_copy) File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 291, in _call raise Fail(err_msg) Fail: Execution of '! beeline -u 'jdbc:hive2://hadoop-node1localdomain.training:10000/;transportMode=binary' -e '' 2>&1| awk '{print}'|grep -i -e 'Connection refused' -e 'Invalid URL'' returned 1. Error: Could not open client transport with JDBC Uri: jdbc:hive2://hadoop-node1localdomain.training:10000/;transportMode=binary: java.net.ConnectException: Connection refused (state=08S01,code=0) Error: Could not open client transport with JDBC Uri: jdbc:hive2://hadoop-node1localdomain.training:10000/;transportMode=binary: java.net.ConnectException: Connection refused (state=08S01,code=0) )

3 REPLIES 3

Guru
@Praneender Vuppala

It Looks like your host name issue.

Can you try t ping this host with port from ambari server ? Also can you check hostname -f command output.

Contributor

I was able to telnet and ping from other host on the port. Not sure what was the cause. I have reinstalled on centOs 7 boxes. It started to work.

Super Guru
jdbc:hive2://hadoop-node1localdomain.training:10000/;transportMode=binary

Given the above URL, can you add "default" db to the URL? I have seen this issue when I didn't specify a database.