Support Questions
Find answers, ask questions, and share your expertise

Hortonworks 2.4.2 + Hue 3.11 + Ubuntu 14.04 + HDP Search

Hortonworks 2.4.2 + Hue 3.11 + Ubuntu 14.04 + HDP Search

New Contributor


HDP is installed using ambari.

Hue is installed manually using + a few steps (libffi-dev,libgmp3-dev,add hue user). HBase explorer is working fine. OOzie view + workflow edit works fine.

HDP search was installed manually using for Ubuntu 14.04. Solr server starts and says Happy searching

Tried configuring HDP search using the link Hbase indexer fails with error Exception in thread "main" java.lang.NoSuchMethodError: org.apache.hadoop.conf.Configuration.addDeprecations([Lorg/apache/hadoop/conf/Configuration$DeprecationDelta;)V at org.apache.hadoop.mapreduce.util.ConfigUtil.addDeprecatedKeys( at org.apache.hadoop.mapreduce.util.ConfigUtil.loadResources( at org.apache.hadoop.mapred.JobClient.<clinit>( at com.ngdata.hbaseindexer.master.IndexerMaster.getJobClient( at com.ngdata.hbaseindexer.master.IndexerMaster.start( at com.ngdata.hbaseindexer.Main.startZooKeeperDependentServices( at com.ngdata.hbaseindexer.Main.startServices( at at com.ngdata.hbaseindexer.Main.main(

Uploaded csv file to HDFS. Using Hue Search App tried to create an index. Got following error

{ "message": "{\"responseHeader\":{\"status\":400,\"QTime\":16135},\"error\":{\"metadata\":[\"error-class\",\"org.apache.solr.common.SolrException\",\"root-error-class\",\"\"],\"msg\":\"Error CREATEing SolrCore 'abcde': Unable to create core [abcde] Caused by: Could not find configName for collection abcde found:[myCollConfigs, myCollConfigs9, patient1, myCollConfigs6, myCollConfigs5, myCollConfigs8]\",\"code\":400}}\n (error 400)", "traceback": [ [ "/usr/local/hue/desktop/libs/libsolr/src/libsolr/", 541, "create_core", "response ='admin/cores', params=params, contenttype='application/json')" ], [ "/usr/local/hue/desktop/core/src/desktop/lib/rest/", 132, "post", "allow_redirects=allow_redirects, clear_cookies=clear_cookies)" ], [ "/usr/local/hue/desktop/core/src/desktop/lib/rest/", 81, "invoke", "clear_cookies=clear_cookies)" ], [ "/usr/local/hue/desktop/core/src/desktop/lib/rest/", 173, "execute", "raise self._exc_class(ex)" ] ], "detail": null, "title": "Error while accessing Solr" }

Looks like a configuration issue. Any help or suggestions will be great!

Best Regards,



Re: Hortonworks 2.4.2 + Hue 3.11 + Ubuntu 14.04 + HDP Search

Rising Star

Hi @vishal vpv,

By the time, could you be able to find a solution for your problem?

Most probably it is a Zookeeper directory issue but I couldn't get over yet. I'd be glad if you can share your later experience.