Support Questions

Find answers, ask questions, and share your expertise

Hortonworks schema registry doesn't work with MySql 8.0.11

New Contributor

Im trying to run the schema registry with mysql version 8.0.11.

When I run it with the 5.7 version, everything works fine. But since our production DB is on 8.0.11, it breaks. 


For the upgraded mysql instance, I made changes to the file. (changed the version of mysql driver to be dowloaded to 8.0.11)


I also made changes to regisrty.yaml to refer to the new datasource class name as mentioned on the Mysql documentation. 


However, When i run this, I notice that the driver jar is not being unzipped and stored in a proper manner. I see classnotFound exception which is because of the error in the steps post unzipping. 


I'm unable to debug further and also cant see a workaround. 


Any help would be highly appreciated!




If you are using Schema Registry bundled with HDF 3.1 to then these versions are not yet certified if you checked the hortonworks supportmatrix ,  see below screenshot



On the other hand, MariaDB the open-source version of MySQL is certified MariaDB 10.2.


Usually, its recommended before any component upgrade to consult the vendor's recommendation. Else open support with Cloudera is you bought support, they have capable engineers who could help you with a workaround or develop some patches or some fallback steps but what am sure of the supportmatrix will be the subject of discussion but having said that as it's production environment if you have support maybe a patch can be built and delivered for you.


If you had backed up the database before the upgrade then the best option, for now, would be to rebuild the older version and undo the changes you made in registry.yaml while you wait for Cloudera to certify newer DB's or move to CDF a rebranding spinoff HDF I am not sure it supports MySQL 10.x

Best of luck