Support Questions

Find answers, ask questions, and share your expertise

Hosts are not added to the Ambari with HA services.

I am trying to create a HA cluster with HA services( HDFS, YARN, HBASE, HIVE, STORM). I am using the minimum required configurations suggested by Hortonworks document via Blueprint.

https://cwiki.apache.org/confluence/display/AMBARI/Blueprint+Support+for+HA+Clusters

Even though, the configs are correct and registering the Blueprint and host template is successful, hosts are not been added to the cluster. When I try to register a single host from UI it is successful. It also tells there are other hosts that are registered with the server (which are the hosts that I want to add to my cluster). So, this tells me that server does recognize all the host yet does not add them to the list of hosts. Don't know why?

capture.png

So, I restarted the ambari-server and few ambari-agents. Soon all the hosts were discovered and added in the ambari host list.

Now, when I check the ambari-server logs, I see following 3 errors which I am not able to figure out.

1. No service found for config types '[cluster-env]', service config version not created.

2. Unable to update configuration property 'xasecure.audit.destination.hdfs.dir' with topology information. Component 'NAMENODE' is mapped to an invalid number of hosts '2'. This tells that it is expecting this config to be present in the Blueprint but this has never popped up before so don't know where, what and how to give this configuration.

3. BaseProvider:240 - Caught exception getting JMX metrics : Connection refused (Connection refused), skipping same exceptions for next 5 minutes. This comes along with Metrics Collector been not alive or something even though it is installed and started successfully. Also metrics monitor are installed on all the hosts.

I am using Ambari 2.2.2.0 with rhel 7.3 and HDP 2.4.3

Any help would be appreciated in understanding this behavior. Thank you.


capture.png
4 REPLIES 4

Expert Contributor

Can you post your creation and blueprint JSON ?

Sorry for late reply, I am attaching the blueprint file. It is a Jinja2 template. Let me know if should I remove the template tags and just post the configuration.blueprint-multi-node-ha-1.txt

Expert Contributor

One comment is RHL 7.3 is not supported with Ambari 2.2.2/HDP2.4.3

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.