Support Questions

Find answers, ask questions, and share your expertise

How do I fix my cluster Ambari update attempt

Expert Contributor

Hi. I tried to upgrade my cluster from Ambari 2.2 to 2.4. I went through the upgrade process got it to run, but the web interface was still showing me a version of 2.2.

I rebooted my cluster and ambari server is running but I cannot connect to it:

Unable to connect to Ambari Server. Confirm Ambari Server is running and you can reach Ambari Server from this machine.

Also 2 machines only boot to a black screen. I can login via terminal but cannot start a GUI. I know this is partly a Ubuntu question but I have tried everything I can find to try and solve this, so I was wondering if anyone had encountered the same issues and maybe could give me some pointers. TIA!!!!!

6 REPLIES 6

Super Mentor

@ed day

What is the output of the following command?

# ambari-server --version

.

Also do you see the PID of ambari server matching the PID file entry?

# ps -ef | grep AmbariServer
# cat /var/run/ambari-server/ambari-server.pid 

.

Do you see that ambari server port is opene successfully?

# netstat -tnlpa | grep 8080

.

Also please che ck and share the "" file to see if there are any WARNING/ERROR message that is causing ambari to not start properly.

/var/log/ambari-server/ambari-server.log
/var/log/ambari-server/ambari-server-check-database.log 

Expert Contributor

Thansk for your help!

# ambari-server --version

2.2.1.0

the PID's are both 2344? (I'm not too familiar with this).

ed@master:~$ ps -ef | grep AmbariServer
root      2344     1 12 20:49 ?        00:01:00 /usr/jdk64/jdk1.7.0_67/bin/java -server -XX:NewRatio=3 -XX:+UseConcMarkSweepGC -XX:-UseGCOverheadLimit -XX:CMSInitiatingOccupancyFraction=60 -Dsun.zip.disableMemoryMapping=true -Xms512m -Xmx4096m -XX:PermSize=128m -XX:MaxPermSize=128m -Djava.security.auth.login.config=/etc/ambari-server/conf/krb5JAASLogin.conf -Djava.security.krb5.conf=/etc/krb5.conf -Djavax.security.auth.useSubjectCredsOnly=false -cp /etc/ambari-server/conf:/usr/lib/ambari-server/*:/usr/share/java/postgresql-jdbc.jar org.apache.ambari.server.controller.AmbariServer
ed        3922  3804  0 20:57 pts/1    00:00:00 grep --color=auto AmbariServer
ed@master:~$ cat /var/run/ambari-server/ambari-server.pid 
2344

No errors in this log: ambari-server.log.

Could not find the other log.

Super Mentor

@ed day

What is the output of the following command?

  1. # ambari-server --version

.

Also do you see the PID of ambari server matching the PID file entry?

  1. # ps -ef | grep AmbariServer
  2. # cat /var/run/ambari-server/ambari-server.pid

.

Do you see that ambari server port is opene successfully?

  1. # netstat -tnlpa | grep 8080

.

Also please check and share the ambari log files to see if there are any WARNING/ERROR message that is causing ambari to not start properly.

  1. /var/log/ambari-server/ambari-server.log
  2. /var/log/ambari-server/ambari-server-check-database.log

.

additionally also please check if you are able to access the ambari host & port from the bachine where you are trying to access the Ambari WebUI. (Assuming that your ambari is running on http port 8080)

# telnet  $AMBARI_FQDN   8080

.

Expert Contributor

Ah it is now connecting! Still saying 2.2.1.0 though.

Expert Contributor

I think the problem is this:

Confirm there is only one ambari-server*.jar file in /usr/lib/ambari-server. If there is more than one JAR file with name ambari-server*.jar, move all JARs except ambari-server-2.4.*.jar to /tmp before proceeding with upgrade.

the jar there is ambari-server-2.2.1.0.161.jar. I'll ask another question.

Super Mentor

@ed day

Try doing "yum reinstall ambari-server" if it does not fix the problem then you should try the below mentioned steps:

.

.

Based on the update it looks like your ambari-server binary upgrade is not completed fine. You should try doing the following to see if it works:

1. Make sure that the Ambari Repo is pointing to the correct link. So we will need to check the following file:

Example:

# cat /etc/yum.repos.d/ambari.repo

 #VERSION_NUMBER=2.4.2.0-136
[Updates-ambari-2.4.2.0]
name=ambari-2.4.2.0 - Updates
baseurl=http://public-repo-1.hortonworks.com/ambari/centos6/2.x/updates/2.4.2.0
gpgcheck=1
gpgkey=http://public-repo-1.hortonworks.com/ambari/centos6/RPM-GPG-KEY/RPM-GPG-KEY-Jenkins
enabled=1
priority=1

2. If you see that it is not pointing to the correct ambari repo then you should download the correct repo file for correct OS (like CentOS6).

Example: For ambari 2.4.2 you can refer to: http://docs.hortonworks.com/HDPDocuments/Ambari-2.4.2.0/bk_ambari-upgrade/content/upgrade_ambari.htm...

# wget -nv http://public-repo-1.hortonworks.com/ambari/centos6/2.x/updates/2.4.2.0/ambari.repo -O /etc/yum.repos.d/ambari.repo

3. Now you should perform a yum clean

# yum clean all
# yum info ambari-server

4. Now perform a Yum Upgrade.

# yum upgrade ambari-server -y

OR else try reinstalling the ambari-server that will fix the missing JAR issue during last installation:

# yum reinstall ambari-server

.

Now verify if all JARs are of correct version or not. Just for safety try running the ambari upgrade command (just to make sure that ambari DB schema is also upgraded).

NOTE:

You should take a Ambari DB Dump before running the ambari server upgrade command just to make sure that we have a safe copy of the ambari DB dump.

# ambari-server upgrade
# ambari-server start

.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.